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Gracias por adquirir el sistema GPS Bluetooth de IOGEAR.  Esta unidad GPS Bluetooth es un
software de navegación en tiempo real. El receptor GPS Bluetooth permite recibir datos de
posicionamiento de los satélites y entregar dichos datos a los dispositivos de cálculo móviles de
forma inalámbrica a través de la tecnología Bluetooth. Proporciona funciones de seguimiento
totalmente fiables y de alta precisión. El diseño de bajo consumo y la pila recargable de larga
duración proporcionan 25 horas de uso continuo y elimina la recarga constante entre usos. Es
portátil y ligero, por lo que puede colocarlo en el control de mandos o en cualquier otra posición
que proporcione una línea de visión directa del espacio.

¡No volverá a perderse nunca más!
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Equipo de sobremesa y portátil

Windows ME/2000/XP
Memoria RAM del sistema de al menos 256 MB y 512 MB de espacio disponible en disco duro
como mínimo.
Debe tener la funcionalidad Bluetooth y ser compatible con el perfil de puerto serie

PDA (Pocket PC)
Requiere Microsoft Pocket PC 2002 o posterior
La unidad PDA debe tener un procesador a 266 MHz como mínimo con al menos 64 MB de
memoria principal disponibles
Se recomienda una tarjeta de almacenamiento de al menos 64 MB para cargar mapas
adicionales
Debe tener la funcionalidad Bluetooth y ser compatible con el perfil de puerto serie

Requisitos del Sistema
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Características de software

• Mensajes de voz en cada giro que le ayudan a fijar la atención en la carretera en todo

momento

• Recálculo de rutas automático que le proporcionan el destino aunque haga un giro erróneo

• Opciones de la ruta más rápida, más corta, local, importante y por turnos

• Pantalla de pautas de maniobras automáticas

• Pantalla de mapas en tiempo real

• Pantalla completa automática

• Pantalla de mapas detallados con los nombres de las calles

• Combinación automática de colores de día y de noche

• Vista de pájaro 3D

• Opción de teclas rápidas que proporcionan accesos directos a través de los botones de la

unidad PDA

• Características de seguridad que incluyen alertas de velocidad y de poca visibilidad
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• Base de datos de puntos de gran interés (POI, Large Points of Interest)

• Destinos favoritos y recientes

• Cuadro de estado de fácil acceso que muestra el tiempo de llegada (ETA), la distancia y la

velocidad

• Grabación y reproducción de ruta

• Modo de demostración que proporciona una simulación de la conducción del viaje

• Base de datos cartográfica Navteq
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Características de software
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Instalación del software

Lista de comprobación

Antes de continuar, compruebe lo siguiente:
• Esta guía asume que ya tiene la

aplicación Microsoft ActiveSync instalada
y configurada para transferir datos entre la
unidad PDA y el equipo.

• Conecte la unidad PDA al equipo
mediante la base o el cable de
sincronización

Instalar el software
1.  Inserte el CD de instalación incluido en el
paquete.  El CD se iniciará automáticamente y
comenzará el procedimiento de instalación.

2.  El asistente de instalación mostrará la
ventana siguiente.  Haga clic en Siguiente [Next]
para continuar.
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3.  Si acepta el contrato de licencia, haga clic
en Sí [Yes].

Instalación del software

4.  En la ventana siguiente, puede seleccionar la
versión del software de navegación que desea
instalar.  Realice la selección y haga clic en
Siguiente [Next].
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5.  Espere unos segundos mientras los archivos
de instalación se transfieren al equipo.

6.  Si activó la casilla de verificación “Pocket
PC”, aparecerá un mensaje similar al que se
muestra en la imagen siguiente.  Si desea
instalar el programa en la memoria principal de
la unidad PDA, haga clic en Sí [Yes].

Instalación del software
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No obstante, si desea instalar el software de
navegación en otra ubicación, haga clic en No. A
continuación, aparecerá una ventana en la que
puede especificar dónde desea instalar los
archivos de programa.  Realice la selección y
haga clic en Aceptar [OK].

Instalación del software

7.  El software preparará los archivos que se
van a instalar en la unidad PDA.
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8.  Compruebe la unidad PDA para ver los
pasos adicionales y completar la instalación del
programa.

Instalación del software
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Instalación del software

9.  Haga clic en Finalizar [Finish] para
completar la instalación y continuar con la
sección siguiente.
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1.  Una vez cargado el software cartográfico, puede seleccionar los mapas que desea instalar en
el dispositivo.  Existen dos métodos para instalar la cartografía: por región o por ciudad.  Si tiene
menos de 64 MB de almacenamiento, se recomienda instalar la cartografía “Por ciudad” [By City].
Sin embargo, si dispone de suficiente espacio de almacenamiento, puede instalar la cartografía
mediante la opción Por región [By Region].

Si observa la parte derecha de la pantalla, verá que puede seleccionar la ubicación de destino
[Target Location] en la que desea cargar los mapas (en la unidad PDA o el equipo).  También
puede ver aquí el espacio de almacenamiento disponible de la ubicación seleccionada y el
tamaño en megabytes de los mapas seleccionados.

Nota: cuando seleccione las áreas de los mapas que desea instalar, el software de navegación
generará un mapa reuniendo todas estas áreas.  Si desea agregar más áreas en otro momento,
el software de navegación necesitará reconstruir todo el mapa; por tanto, necesita seleccionar
todos los mapas anteriores, más el que está agregando.

Cargar los mapas
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Método 1 - Por región:
Utilice esta opción si desea instalar mapas
para todo un estado.  Si el estado que elija
tiene un signo “+” junto a su nombre,
significa que, si lo desea, puede instalar sólo
partes del estado en cuestión (tal y como
muestra la imagen siguiente).  Para cargar el
mapa de todo el estado, asegúrese de
activar todas las casillas de verificación que
se encuentren bajo el signo “+”.

Cuando haya seleccionado todos los mapas
que desea, haga clic en “Generar mapa”
[Generate Map] para iniciar la instalación del
mapa.

Cargar los mapas
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2.  Alternativamente, si el espacio de
almacenamiento del equipo o la unidad PDA
es limitado, puede cargar los mapas
mediante la opción Por ciudad [By City].

Método 2 - Por ciudad:

En primer lugar seleccione una región
(estado) para el mapa que desea.  A
continuación seleccione la ciudad y el radio
del mapa en el que pretende utilizar el
sistema GPS.

En Ubicación de destino [Target Location],
especifique el lugar donde desea cargar
los mapas.  Cuando esté listo para iniciar
la instalación de los mapas, haga clic en
“Generar mapa” [Generate Map].

Cargar los mapas
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3.El software de instalación comenzará ahora
a instalar los mapas.

4. En función de las selecciones realizadas, el
sistema le puede pedir que inserte el CD en
el que se encuentran los datos cartográficos.
Insértelo y haga clic en Aceptar [OK] para
continuar.  Nota:  tenga paciencia, ya que la
instalación de los mapas puede tardar hasta
30 minutos, dependiendo del tamaño de los
mapas que se vayan a cargar.

Cargar los mapas
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CONFIGURAR EL SOFTWARE QUE VA A
UTILIZAR CON LA UNIDAD GPS

Lista de comprobación

Antes de continuar, compruebe lo siguiente:
- La unidad Bluetooth esta ENCENDIDA y tiene
una vista despejada del espacio

- La unidad GPS ha establecido una coneccion
Bluetooth serie con su equipo Bluetooth

- Ha instalado el software de navegación en el
dispositivo

-Ha instalado todos los mapas que desea

5.  Cuando la instalación termine, aparecerá
una ventana similar a la siguiente:

Configurar el software
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1.  Establezca una conexión de puerto serie
Bluetooth entre el equipo o la unidad PDA y la
unidad GPS Bluetooth, tal y como se describe
en la “Guía de inicio rápido de hardware”.  Si no
realiza este paso, el software no podrá encontrar
la unidad GPS.

2.  Vaya a la carpeta de programas de la
unidad PDA y puntee en el icono de mapa allí
situado para cargar el software de navegación.

Configurar el software
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3.  Durante el inicio, aparecerá un mensaje de
advertencia relacionado con los pasos que se
deben seguir para garantizar la seguridad
mientras se utiliza el equipo GPS.  Sólo tiene
que hacer clic en Aceptar [OK] para continuar.

4. Si ya ha establecido la posición GPS, el
mapa mostrará la posición actual.  De lo
contrario, mostrará la última posición conocida.

Configurar el software
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Los iconos que aparecen en la pantalla permiten cambiar rápidamente la configuración más
utilizada del software de navegación.

Permite ACTIVAR y DESACTIVAR el volumen de los comandos de voz

Permite especificar el destino, cambiar a la vista de mapa, cambiar las opciones de ruta
y visualización, establecer la alerta de velocidad, grabar información de ruta, ajustar el
volumen y ver información GPS.

Ver información GPS

Cambiar la orientación

En la parte inferior de la pantalla hay tres opciones de menú: Archivo [File], Herramientas [Tools]
y Vista [View]. Para obtener una explicación detallada de estos menús, vaya a la página 30.

Configurar el software
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5.  Lo primero que queremos hacer es
configurar el software de navegación para
detectar la unidad GPS Bluetooth.  Para ello,
haga clic en Herramientas [Tools] y seleccione
Opciones GPS [GPS Options].

6.  Ahora, seleccione Deteccion automática
[Auto Detect].

Configurar el software
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7.  El software de navegación comenzará la
detección de la unidad GPS.  Sólo tiene que
hace clic en Aceptar [OK] para realizar la
búsqueda.

8.  En este momento, si la unidad PDA no ha
establecido ninguna conexión con la unidad
GPS Bluetooth, puede aparecer una ventana en
la que se mostrarán todos los dispositivos
Bluetooth que se encuentren dentro de la
cobertura.  Si es así, seleccione la unidad GPS
Bluetooth y haga clic en Aceptar [OK].  No
obstante, si después de varios intentos el
software de navegación no puede detectar al
unidad GPS, asegúrese de que ha seguido el
procedimiento descrito en la Guía de inicio
rápido de hardware para establecer una
conexión de puerto serie entre el dispositivo y la
unidad GPS.

Configurar el software
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También se le puede solicitar que inserte una
contraseña o código NIP.  En este caso, inserte
“0000” (cuatro ceros) y haga clic en Aceptar
[OK].

Configurar el software



22

9. Cuando el software haya detectado la unidad GPS, sólo tiene que hacer clic en Aceptar [OK]
para confirmar la configuración.

Configurar el software



23

10. Cuando haya establecido conexión con la
unidad GPS, aparecerá la vista de mapa.  Pase
a la siguiente sección “Comprobar la conexión
con los satélites GPS”.

COMPROBAR LA CONEXIÓN CON LOS
SATÉLITES
1.  El siguiente paso es comprobar que la
unidad GPS ha establecido su posición.  Para
ello, haga clic en Vista [View] > Estado de GPS
[GPS Info].

Comprobar la conexión con los satélites
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2.  Si la unidad GPS ha establecido su posición,
aparecerá una ventana similar a la siguiente.
Las barras de color verde indican los satélites
con los que la unidad GPS ha establecido un
enlace.  Las barras de color rojo indican que un
enlace con un satélite determinado no se ha
establecido.  Para utilizar la unidad GPS, es
necesario estar conectado a al menos tres (3)
satélites.

Posición GPS establecida:
En este caso, puede ver que la unidad GPS
está conectada a 7 de 7 satélites:

Comprobar la conexión con los satélites
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Posición GPS desconocida:
En este caso, puede ver que la unidad GPS no
ha establecido su posición GPS ni un enlace
con ningún satélite, lo que se indica mediante
las barras de color rojo.

Si la unidad GPS tiene problemas para
establecer un enlace con los satélites, intente
llevar a cabo las tareas siguientes:

• Aleje la unidad GPS de los edificios y
estructuras altos

• Aleje la unidad GPS de cualquier objeto que
pueda interferir con las señales inalámbricas

• Coloque la unidad GPS en una ubicación en
la que tenga una vista despejada del espacio
(preferiblemente en exteriores)

Comprobar la conexión con los satélites
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INTRODUCCIÓN: PROCEDIMIENTOS
INICIALES

Vista de mapa

Iconos de acceso directo
Como puede ver en la imagen anterior, hay una
serie de iconos de acceso directo en la pantalla
que permiten obtener acceso fácilmente a la
mayoría de las tareas comunes asociadas con el
software de navegación.  Para obtener acceso a
todas las funciones de software, haga clic en los
menús Archivo [File], Herramientas [Tools] y
Vista [View] que se encuentran en la parte
inferior de la pantalla (se describen posterior-
mente en el manual).

Introducción: Procedimientos Iniciales
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En la siguiente sección se explican
brevemente cada una de estas funciones y
su uso.

Permite ACTIVAR y DESACTIVAR el
sonido del software de navegación

Permite ver información de estado
GPS

Permite cambiar la orientación del
mapa

Presione el signo más para ampliar un
área;

presione el signo menos para reducir
un área

Iconos de estado GPS
Estos iconos se muestran en el área del mapa y
representan lo siguiente:

Estado GPS: enlace realizado con los
satélites

Estado GPS: intentando conectarse de
nuevo

Estado GPS: no se ha establecido
enlace con suficientes satélites

Introducción: Procedimientos Iniciales
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Estos iconos permiten hacer lo siguiente:

Muestra el área situada alrededor del
destino seleccionado en el mapa

Muestra la posición actual en el mapa

Para establecer una dirección como
favorita, haga clic en este botón

Panorámica de mapa

Si desea ver las áreas situadas alrededor de
la ubicación actual en el mapa, utilice la
función de panorámica.  Para ello, puntee en
la pantalla de la unidad PDA, mantenga el
buril en el mapa, muévalo a lo largo de la
dirección que desea ver y, a continuación,
suéltelo.  El mapa se centrará en esa posición.
Para salir de este modo y volver a la posición
actual, haga clic en la X de color rojo situada
en la esquina inferior derecha.

Opciones de mapa

Introducción: Procedimientos Iniciales
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Al puntear en el icono de menú
aparecerá el menú principal que se
muestra a continuación.

Introducción: Procedimientos Iniciales
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Parte I - Menú de Archivo

Parte I - Menú de Archivo [File]
MENÚ ARCHIVO [FILE]

1.  Especificar destino [Enter Destination]
(menú Archivo [File] →→→→→     Especificar destino
[Enter Destination])
Esta opción de menú permite establecer una
ubicación y proporciona direcciones manzana a
manzana.  Como puede ver en el menú inferior,
hay varias formas de establecer un destino.

A continuación se proporcionan varios ejemplos
para su referencia.  Si sigue necesitando
asistencia, utilice el menú de ayuda del software
de navegación seleccionando Archivo [File] →→→→→
Ayuda [Help].



A. Establecer destino – Dirección [Set
Destination – Address]
Cuando seleccione la opción Dirección
[Address], aparecerán dos opciones:

Calle primero [Street First]: mediante esta
opción normalmente se generarán más
resultados de búsqueda pero es muy útil si tiene
problemas para encontrar una dirección
específica.

Ciudad primero [City First]: esta opción resulta
de gran utilidad porque reduce los resultados de
la búsqueda a la ciudad que especifique.
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Parte I - Menú de Archivo



Calle primero [Street First]
Especifique el nombre de la calle y, a
continuación, haga clic en el botón Aceptar [OK]
de color verde.
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Parte I - Menú de Archivo



Ahora inserte el número de la casa del destino,
teniendo en cuenta el intervalo válido mostrado.
A continuación, haga clic en el botón Aceptar
[OK] de color verde para continuar.

Nota: si la dirección que busca se encuentra
fuera del intervalo mostrado, probablemente no
disponga del mapa necesario para esa área.
Este podría ser el caso si cargó los mapas
utilizando la opción “Por ciudad” [By City].  En
este caso, cargue un área radial más grande
para el mapa o seleccione la opción “Por región”
[By Region] cuando cargue el mapa.
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Parte I - Menú de Archivo



El software de navegación mostrará ahora una
lista de las direcciones coincidentes.  Como se
mencionó anteriormente, mediante la opción
“Calle primero” [Street First] normalmente se
generarán varias direcciones coincidentes.
Seleccione la dirección y, a continuación, haga
clic en Aceptar [OK] en la esquina superior
derecha.
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Parte I - Menú de Archivo



Ciudad primero [City First]
Especifique el nombre de la ciudad y, a
continuación, haga clic en el botón Aceptar [OK]
de color verde
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Parte I - Menú de Archivo



Ahora especifique el nombre de la calle y haga
clic en Aceptar [OK].

Especifique el número de la casa, teniendo en
cuenta el intervalo válido mostrado.
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Parte I - Menú de Archivo



El software de navegación mostrará las
direcciones coincidentes encontradas.  Como
puede ver a continuación, mediante la opción
“Ciudad primero” [City First] se reducen los
resultados de la búsqueda.  Seleccione la
dirección que desea y, a continuación, haga clic
en Aceptar [OK] en la esquina superior derecha.
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Parte I - Menú de Archivo



B. Establecer destino – Cruce [Set Destination – Intersection]
Utilizando esta opción, puede introducir los nombres de dos calles que se crucen como destino

Calle primero [Street First]

No le recomendamos elegir esta opción en el
caso de una intersección ya que la mayoría del
tiempo entregará demasiados resultados.  Sin
embargo, si sólo ha cargado un mapa pequeño
en el dispositivo, no se encontrará con este
problema.

Introduzca el nombre de la primera calle y haga
clic en Aceptar [OK]
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Parte I - Menú de Archivo
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Como puede ver, existen demasiadas
coincidencias.  Haga clic en Aceptar [OK] para
probar la opción de búsqueda por ciudad.

Ciudad primero [City First]
Introduzca el nombre de la primera ciudad y
haga clic en Aceptar [OK]

Parte I - Menú de Archivo
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Introduzca el nombre de la primera calle y haga
clic en Aceptar [OK]

Introduzca el nombre de la segunda calle y haga
clic en Aceptar [OK]

Parte I - Menú de Archivo
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En este caso, el software de navegación no ha
encontrado ninguna coincidencia para esta
intersección, y utilizará la opción “primera
ciudad” [city first] que nos ayudó a filtrar los
resultados de búsqueda para obtener sólo un
registro coincidente.  Haga clic en Aceptar [OK]
en la esquina superior derecha para mostrar el
mapa.

Parte I - Menú de Archivo
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C. Establecer destino – Centro Ciudad [Set Destination – City Center]
Se buscarán los centros de la ciudad en su área.

Por ejemplo, escogeremos la opción Alfabética
Introduzca el nombre de su ciudad y haga clic
en Aceptar [OK].

Parte I - Menú de Archivo



43

Ahora, haga clic en el botón Aceptar [OK] en la
esquina superior derecha.  Si hace clic en el
botón [Nav] en la parte inferior, el software de
navegación le mostrará un mapa del destino.

D. Establecer destino – Puntos de Interés
[Set Destination – Points of Interest]
El sistema posee una función muy útil llamada
Puntos de Interés [Points of Interest] (Abreviado
POI).  Como puede ver en la siguiente imagen,
los POIs se encuentran clasificados en
categorías para un acceso rápido y sencillo.

Parte I - Menú de Archivo
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En Atracciones [Attraction], encontramos las
subcategorías listadas a continuación.
Escogeremos Parques de Atracciones
[Amusement Park] en nuestro ejemplo.

Por ejemplo, seleccionaremos Atracciones
[Attraction].

Parte I - Menú de Archivo
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Haga su selección en la lista siguiente.
Seleccionaremos Alfabético [Alphabetical] para
ver todos lso parques de atracciones cercanos a
su área.

En la lista siguiente, realice su selección, y
haga clic en Aceptar [OK].

Parte I - Menú de Archivo
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Para mostrar el mapa de los POI, haga clic en
Aceptar [OK] en la esquina superior derecha.
Alternativamente, puede hacer clic en los
botones [Nav] o [Map] en la parte inferior de la
pantalla.

Parte I - Menú de Archivo
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Para seleccionar un destino que haya
introducido previamente como Destino Favorito
[Favorite Destination], haga clic en esta
selección.  Realice su selección en la lista y
haga clic en los botones [Nav] o [Map] en la
parte inferior de la pantalla.

Nota: Puede editar o borrar cualquier entrada de esta ventana
haciendo clic en los botones Editar [Edit] o Borrar [Del],
respectivamente.

Parte I - Menú de Archivo

E. Establecer destino – Favoritos [Set Destination – Favorites]
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F. Establecer destino – Recientes [Set Destination – Recent]

Todos los destinos que ha utilizado reciente-
mente se almacenan en este lugar.  Si desea
fijar más de uno como destino, selecciónelos en
la lista siguiente y haga clic después en el botón
[Nav] o [Map] en la parte inferior de la pantalla
para mostrar el mapa.

Parte I - Menú de Archivo
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2. Guardar Posición Actual [Save Current Location] (Archivo [File] → → → → →  Anadir Origen a
Favoritos [Save Current Location]) – le permite guardar su posición actual en el mapa.  Esta
posición se guardará en su carpeta de Favoritos.

Parte I - Menú de Archivo
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3. Cancelar Ruta [Cancel Route]
(Archivo [File] à Cancelar Ruta [Cancel Route])
– Utilice esta opción para cancelar una ruta
que haya introducido
Truco: Para verificar que se ha borrado la ruta,
puede hacer clic en Vista [View] à Lista de
Rutas [Route List], lo cual le mostrará una
ventana vacía como la siguiente:

Parte I - Menú de Archivo
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4.  Grabar Ruta de GPS [Record Track]
(Archivo [File] à Grabar Ruta de GPS [Record
Track]) – Para registrar su viaje, haga clic en
registrar traza [record track], lo cual le mostrará
la siguiente ventana.  Introduzca la información
solicitada y haga clic en Aceptar [OK] para
comenzar el registro.

Parte I - Menú de Archivo
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5.  Reproducir rastro GPS  [Play Track]
(Archivo [File] à Reproducir rastro GPS [Play
Track]) - reproduce una traza previamente
registrada.

Para reproducir una traza grabada con
anterioridad, haga clic en reproducir traza [play
track] y seleccione el archivo que desea
reproducir.  Truco: Para detener la reproducción
de la traza, haga clic en Archivo [File] à Detener
grabacion [Stop Track].

Parte I - Menú de Archivo
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6.  Demo de ruta actual [Start Demo] (Archivo
[File] à Demo de ruta actual [Start Demo])
Una de las funciones más útiles del programa
de navegación es la función de Demostración
[Demo], que le permite ver una demostración de
su ruta real para el destino especificado.  Esto
resulta muy útil en el caso de que necesite
ajustar/cambiar opciones en su PDA, ya que
puede hacerlo cómodamente antes de
comenzar a conducir.
Truco:  Si hace clic en Iniciar Demostración
[Stara Demo] y no ocurre nada, recuerde que
antes necesita especificar un destino.

7.  Acerca del Sistema de Navegación [About
Navigation System] (Archivo [File] à Acerca del
Sistema de Navegación [About Navigation

System]) – muestra la ventana de información
del programa de mapas
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8.  Ayuda [Help] (Archivo [File]  Ayuda [Help])
– muestra los contenidos de la ayuda
incorporada en el software de navegación.  Esta
es una función muy útil si necesita una
explicación rápida sobre cómo llevar a cabo
ciertas tareas en el software de navegación.

9.  Salir [Exit] (Archivo [File] à Salir [Exit]) – sale
del programa y lo descarga de la memoria de su
PDA
.

54

Parte I - Menú de Archivo



Part II, MENÚ DE HERRAMIENTAS (TOOLS MENU)
1.  Funciones de Seguridad [Safety Features]
(Herramientas [Tools] → Funciones de
Seguridad [Safety Features]) – le ayuda a hacer
más segura su conducción.

Alerta de Velocidad [Speed Alert]
Si desea recibir una alerta sonora cuando
alcance un determinado límite de velocidad,
active la alerta de velocidad [speed alert].  Si lo
configura en Automático [Auto], el software de
navegación determinará el límite de velocidad
basándose en el tipo de carretera en la que se
encuentre (calle, autopista, etc.).  Sin embargo,
esta alerta es sólo para uso personal, y no se
garantiza que sea precisa.  Le aconsejamos
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Conducción con Niebla [Fog Driving]
Si activa esta opción, el programa le notificará
cuándo se aproxima una intersección.
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2.  Unidades de Distancia [Distance Units]
(Herramientas [Tools] →  Unidades de Distancia
[Distance Units]) – le permite cambiar las
unidades a mostrar en las distancias de su
software de navegación.
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3.  Opciones de Ruta [Route Options]
(Herramientas [Tools] → Opciones de Ruta
[Route Options]) – personalice el programa para
ofrecerle instrucciones basándose en sus
preferencias.  A continuación se presenta una
breve explicación acerca de estas opciones.
Para más información, utilice el menú ayuda
[help] (Archivo [File] → Ayuda [Help])
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Método [Method]
Más Rápido [Quickest] – Le ofrece
instrucciones que le llevarán a su destino de la
forma más rápida (tomando por ejemplo las
autopistas en largos viajes y evitando las calles
locales congestionadas)

Más Corto [Shortest] – Le ofrece instrucciones
basadas en la ruta más corta según la distancia
física (puede no ser la ruta más rápida)

Principal [Major] – Le ofrece instrucciones
basadas en las calles principales (si no quiere
perderse por calles desconocidas)

Local [Local] - Le ofrece instrucciones basadas
únicamente en calles locales (evitando
autopistas)

4.  Opciones de Pantalla [Display Options]
(Herramientas [Tools] → Opciones de Pantalla
[Display Options])
A continuación se presenta una breve
explicación acerca de estas opciones.  Para más
información, utilice el menú de ayuda (Archivo
[File] → Ayuda
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Orientación del Mapa [Map Orientation] –
cambie esta configuración basándose en su
orientación para ver mejor el mapa.

Modo de visualizacion [Color Scheme]
Automática [Auto] – cambia la visualización de
pantalla entre día/noche [day/night] y atardecer/
amanecer [subset/sunrise], respectivamente
Día [Day] - la pantalla se presenta en modo
normal para visión diurna
Noche [Night] – el fondo del mapa se oscurece y
las líneas de las carreteras se resaltan para una
mejor visualización

Mostrar maniobras detalladas [Guidance
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Screen] – si se configura en Automático [Auto]
acercará el mapa cuando se esté aproximando a
la área, o haga clic manualmente en la área.
Opciones de punto de interes [POI Icons] – si
está activado, el mapa muestro iconos durante
la conducción de la posición de los POI en la
base de datos del mapa

Perspectiva de mapa [3D Map View] – puede
cambiar la vista del mapa a 3D para obtener una
visión más realista

5.  Opciones de Atajo [Hotkey Options]
(Herramientas [Tools] → Opciones de Atajo
[Hotkey Options]) – asigna un botón de su PDA
a una tarea concreta
Esta es una función muy útil del programa que
le permite asignar cualquiera de los botones de
su PDA para llevar a cabo alguna de las
funciones del software de navegación pulsando
solamente un botón.

Sólo tiene que seleccionar una función de la
lista, y hacer clic después en el botón de su
PDA que desea que lleve a cabo esa función.
Después de hacerlo, verá el botón # mostrado
en la pestaña llamada “botón [button]”.  Si
quiere deshacerlo, puede hacer clic en Borrar
Tecla [Clear Key] para la función seleccionada,
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o “Borrar Todo [Clear All]” para borrar todos los
botones asignados.

Las funciones que puede asignar a un botón de
su PDA son:
Modo 3D [3D Mode]
Posición Actual [Current Position]
Personalizar Iconos POI [Customize POI Icons]
Desvío [Detour]
Opciones de Pantalla [Display Options]
Introducir Destino [Enter Destination]
Pantalla Completa [Fullscreen]
Estado de GPS [GPS Info]
Menú [Menu]
Mudo [Mute]
Norte/Hacia arriba [North/Heading Up]

Activar/Desactivar Iconos POI [POI Icons On/
Off]
Lista de Rutas [Route List]
Opciones de Ruta [Route Options]
Alerta de Velocidad [Speed Alert]
Volumen [Volume]
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6.  Opciones de teclado [Input Options]
(Herramientas [Tools] → Opciones de teclado
[Input Options]) – le permite definir cómo
introducir información en el software de
navegación

Teclado Pocket PC [Pocket PC Keyboard] –
todas las entradas del usuario deberán
realizarse por medio del teclado en pantalla de
su PDA. (en este caso haciendo clic en el icono
de teclado que verá en la esquina inferior
derecha de la siguiente imagen).

Teclado del Software de Navegación – utilice el
teclado incorporado del software de navegación
para realizar todas las entradas.  Esto resulta
mucho más adecuado ya que las teclas se
muestran más grandes en la PDA, y aún podrá

utilizar el teclado de su Pocket PC si así lo
desea.
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7.  Opciones de GPS [GPS Options]
(Herramientas [Tools] → Opciones de GPS
[GPS Options] - seleccione manualmente las
opciones de su unidad GPS o configúrelas con
la función de Detección Automática [Auto
Detect]

Nota: El número de puerto COM es el número
del Puerto COM Saliente que su Ordenador/
PDA utiliza para conectarse a la unidad GPS.
Configure esta opción manualmente si está
seguro de qué puerto COM utiliza su PC/PDA.
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La Velocidad en Baudios (Baud Rate) debe
configurarse en 4800

8.  Volumen de Guía [Guidance Volume]
(Herramientas [Tools] → Volumen de Guía [Guidance
Volume]) – le permite ajustar el nivel de volumen del
software de navegación para los comandos de voz.
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Part III MENÚ DE VISTA [VIEW MENU] 1.  Mapa [Map] (Vista [View] → Mapa [Map])
– le lleva de nuevo a la vista de mapa

2.  Maniobras detalladas [Guidance] (Vista
[View] → Maniobras detalladas [Guidance]) –
Acerca su posición actual y le informa de la
siguiente maniobra (p. Ej.: gire a la izquierda/
derecha).

Truco: De forma predeterminada, esto lo hace
automáticamente el software de navegación.
Si desea cambiarlo, diríjase a: Herramientas
[Tools] à Opciones de Pantalla [Display
Options] à Pantalla de Guía [Guidance Scree]
à Automático/Manual [Auto/Manual]
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3.  Instrucciones de ruta [Route List] (Vista
[View] → Instrucciones de ruta [Route List]) -
muestra instrucciones en texto sobre cómo
llegar a su destino
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4.  Estado de GPS [GPS Info] (Vista [View] →
Estado de GPS [GPS Info]) – muestra
información de estado del GPS y otra
información útil

Hora UTC [UTC Time] - Hora Coordinada
Universal
Hora Local [Local Time] – La hora en su área

En Posición [Location], también puede ver su
Latitud, Longitud y Altitud.

NMEA – Asociación de Electrónica Marina
Internacional [National Marine Electronics
Association]  La información mostrada en esta
ventana muestra alguna información recibida a
través de la unidad GPS.
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5.  Almanaque [Almanac] (Vista [View] →
Almanaque [Almanac]) - Muestra información
sobre el Sol/Luna [Sun/Moon]

6.  Acercar/Alejar [Zoom in/Zoom out] (Vista
[View] → Zoom +/Zoom -) - Haga clic en esta
opción para acercar/alejar la área.
Alternativamente, puede hacer clic en los
botones azules +/-
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Si necesita una lista más completa de Solución de Problemas/Preguntas Frecuentes, consulte la
sección Resolución de Problemas [Troubleshooting] y Preguntas Frecuentes [Frequently Asked
Questions] en el programa de navegación (Archivo [File] -> Ayuda [Help]).

1.  Durante la instalación de un mapa, obtengo un error de escritura.
Esto puede ser debido a que no hay memoria suficiente en su Ordenador/PDA.  Instale los
mapas en otro lugar o instale más memoria en su dispositivo.

2.  Mi GPS Bluetooth IOGEAR no puede establecer una posición.
Asegúrese de que utiliza la unidad en una área exterior, lejos de construcciones altas o cualquier
objeto que pueda causar interferencias.  Además, asegúrese de que el GPS está totalmente
cargado (llevará unas 3 horas completar la carga).

Si aún no puede establecer una posición, reinicie el GPS como se indica en la Guía de Inicio
Rápido de Hardware (Hardware Quick Start Guide).

Resolucion De Problemas
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3.  Mi PDA no responde o va muy lenta después de cargar el Software de navegación.
En primer lugar, asegúrese de que su PDA cumple los requisitos mínimos de sistema.  Quizá
quiera también comprobar todos los Programas en Ejecución de su PDA.  Si tiene demasiados
programas en ejecución en segundo plano, puede que estén consumiendo demasiada memoria,
ralentizando así su PDA.

4.  El programa de Navegación no carga en PC/PDA.
Asegúrese de que su PDA cumple los requisitos mínimos de sistema.

5.  Tengo problemas al establecer la comunicación Bluetooth entre mi PC/PDA y la unidad GPS.
Consulte la Guía de Inicio Rápido de Hardware (Hardware Quick Stara Guide) para saber cómo
hacerlo.  Si aún tiene problemas, consulte el manual de usuario de su dispositivo Bluetooth.

Resolucion De Problemas
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Para ayudar a los clientes de IOGEAR® a obtener el nivel más alto de rendimiento de su tarjeta
CardBus USB 2.0 / FireWire®, el equipo de Soporte técnico de IOGEAR® está a su disposición
para responder a sus preguntas técnicas. No dude en llamar si no logra que su tarjeta funcione
correctamente. Puede contactar con el Servicio de soporte técnico de IOGEAR® llamando al
teléfono (866)946-4327 de 08:00 a 17:00 (hora estándar del Pacífico), de lunes a viernes o en la
siguiente dirección:

23 Hubble Drive
Irvine, CA 92618

También puede ponerse en contacto con nosotros a través de la dirección Web www.iogear.com/
support durante las 24 horas del día. Antes de llamar al Servicio de soporte técnico, tenga
preparada una breve descripción del problema y lo que estaba haciendo cuando sucedió.
La ayuda del representante del Servicio de soporte técnico será más rápida y eficaz si está
preparado para responder las ocho preguntas que se indican seguidamente.

1) ¿Cuál es la fecha de compra y el número de serie de la tarjeta?
2) ¿Se mostró algún mensaje en la pantalla cuando se produjo el error? En caso afirmativo, ¿cuál

Soporte técnico
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Soporte técnico

era el texto exacto del
     mensaje?
3) ¿Qué tipo de equipo utiliza?
4) ¿Cuándo tiene lugar el problema?
5) ¿Puede reproducir el problema? Si es así, ¿cuáles son los pasos necesarios para
reproducirlo?
6) ¿Qué versión de sistema operativo utiliza?
7) ¿Está conectado en red? Si lo está, ¿qué tipo de red es?
8) ¿Ha intentado solucionar el problema de alguna manera?



¡¡¡ADVERTENCIA!!!  Este equipo genera, utiliza y puede emitir energía de radiofrecuencia y, si no
se instala y se utiliza conforme al manual de instrucciones, puede provocar interferencias
perjudiciales a las comunicaciones de radio.  Este equipo se ha probado y se ha establecido que
cumple con los límites de un dispositivo informático de Clase B con relación al subapartado J del
apartado 15 de la normativa FCC, diseñadas para proporcionar una protección razonable contra
estas interferencias al utilizarse en un entorno comercial.  Es probable que el funcionamiento de
este equipo en un zona residencial cause interferencias perjudiciales, en cuyo caso, será
necesario que el usuario, por su cuenta, tome las medidas oportunas para evitar las
interferencias.

Declaración sobre interferencias de radio y TV
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EN NINGÚN CASO, EL PROVEEDOR DIRECTO SERÁ RESPONSABLE DE NINGÚN DAÑO
DIRECTO, INDIRECTO, ESPECIAL, INCIDENTAL O CONSECUENTE RESULTANTE DEL USO
DEL PRODUCTO, DISCO O SU DOCUMENTACIÓN SUPERIOR AL PRECIO PAGADO POR EL
PRODUCTO.

El proveedor directo no representa ni otorga ninguna garantía expresa, implícita o legal respecto
al contenido o uso de esta documentación, y renuncia expresamente a su calidad, rendimiento,
comerciabilidad o idoneidad para ningún fin determinado.

El proveedor directo también se reserva el derecho a revisar o actualizar el dispositivo o
documentación sin tener la obligación de notificar a ningún individuo o entidad tales revisiones o
actualizaciones.  Si tiene alguna pregunta no dude en ponerse en contacto con su proveedor
directo.

Garantía limitada
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Información de contacto.

23 Hubble Drive  •  Irvine, California  92618  •  (P) 949.453.8782   •  (F) 949.453.8785   •  www.iogear.com

®




