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Bem-vindo

Obrigado por ter comprado o sistema GPS Bluetooth da IOGEAR.  Esta unidade
de GPS Bluetooth é um sistema de navegação em tempo real. O receptor GPS
Bluetooth permite-lhe receber dados via satélite relativos ao seu posicionamento
e estabelecer a ligação a dispositivos de computação portáteis através da
especificação sem fios Bluetooth. Este sistema proporciona uma alta precisão e
capacidades de rastreio fiáveis. O design de baixo consumo e a longa duração da
bateria recarregável dão-lhe 25 horas de utilização contínua e elimina a
necessidade de carregamentos constantes entre utilizações. Este dispositivo é
portátil e leve, pelo que pode colocá-lo no painel de instrumentos ou em qualquer
outro local com boa visibilidade a céu aberto.

Desta forma, nunca mais andará perdido!
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Requisitos do sistema

Laptop/Desktop:

Windows ME/2000/XP
Um mínimo de 256 MB ao nível da RAM e pelo menos 512 MB de espaço
disponível no disco rígido
Deve ser compatível com a norma Bluetooth e suportar o perfil SPP

Agenda electrónica (Pocket PC):

Necessita do Microsoft Pocket PC 2002 ou acima
A agenda electrónica deve ter um processador de pelo menos 266 MHz com um
mínimo de 64 MB de espaço livre na memória principal
Recomendamos a utilização de um cartão de memória com pelo menos 64 MB
de capacidade de armazenamento para que possa carregar os mapas adicionais
Deve ser compatível com a norma Bluetooth e suportar o perfil SPP



Características do software
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• Instruções faladas em cada ponto de viragem para que possa concentrar a
sua atenção na estrada

• Criação automática de um novo percurso para que possa chegar ao seu
destino após ter virado no local errado

• Várias opções de percursos mais rápidos, mais curtos, locais ou principais
para as situações de partilha do mesmo carro por várias pessoas

• Ecrã de orientação para manobras automáticas
• Visualização de mapas em tempo real
• Ecrã inteiro automático
• Apresentação detalhada de mapas com nomes de ruas
• Esquema de cores automático para condução diurna e nocturna
• Resumo 3D
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• Possibilidade de poder utilizar as teclas da sua agenda electrónica como
teclas de atalho

• Capacidades especiais de segurança incluindo velocidade e alerta de
nevoeiro

• Grande base de dados com locais de interesse (POI)
• Destinos favoritos e recentes
• Caixa de estado de fácil acesso com apresentação da hora prevista de

chegada, a distância e a velocidade
• Gravação e reprodução de percursos
• Modo de demonstração para que possa fazer uma simulação da sua viagem
• Base de dados cartográfica Navteq

Características do software



Instalação do software

Lista de verificação

Antes de prosseguir, verifique o seguinte:

• Este guia parte do princípio de que já tem o Microsoft ActiveSync instalado e
configurado para transferência de dados entre a sua agenda electrónica e o
computador.

• Ligue a sua agenda electrónica ao computador através do respectivo suporte
ou do cabo de sincronização
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Instale o software

1. Introduza o CD de instalação que
vem incluído na embalagem.  O CD
é iniciado e procede automaticamen-
te à instalação.

2. assistente de instalação apresenta a
janela mostrada em baixo.  Clique
em “Seguinte” (Next) para continuar.

Instalação do software



Se aceitar o Acordo de
licença, clique em Sim (Yes).

3.
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Instalação do software



Na janela seguinte, pode
seleccionar a versão do
software de navegação que
pretende instalar.  Faça a
sua selecção em baixo e de
seguida clique em Seguinte
(Next).

4.
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Instalação do software



Aguarde alguns
momentos enquanto os
ficheiros de instalação
são transferidos para o
computador.

5.
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Instalação do software



Se assinalou a caixa “Pocket PC”,
obterá uma mensagem semelhante
à da imagem em baixo.  Se desejar
instalar o programa na memória
principal da sua agenda electrónica,
clique em Sim (Yes).

No entanto, se quiser instalar o software
de navegação num outro local, clique em
Não (No).  Ser-lhe-á então apresentada
uma janela onde pode especificar o local
onde pretende instalar os ficheiros do
programa.  Faça a sua selecção e de
seguida clique em OK.

6.
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Instalação do software



O software prepara os ficheiros para
instalação na sua agenda electrónica.

Consulte a sua agenda electrónica
para informações adicionais sobre
como concluir a instalação do
programa.

7. 8.
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Instalação do software



Clique em Concluir (Finish)
para concluir a instalação e
passar à secção seguinte.

9.
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Instalação do software



1.  Depois de carregado o software
cartográfico, pode seleccionar os
mapas que deseja instalar no seu
dispositivo.  Existem dois métodos para
instalação dos mapas - por região ou
por cidade.  Se tiver menos de 64 MB
de capacidade de armazenamento,
recomendamos a instalação dos mapas
“Por cidade” (By City).  No entanto, se
tiver espaço de armazenamento
suficiente, pode instalar os seus mapas
utilizando a opção “Por região” (By
Region).

Se olhar para o lado direito, poderá
seleccionar o Local de destino (Target

Location) para onde pretende carregar
os mapas (na sua agenda electrónica
ou no computador).  Nesta janela,
poderá também ver a capacidade de
armazenamento disponível no local
seleccionado e o tamanho em
megabytes dos mapas seleccionados.
here the available storage space of your
selected location, and the size in
megabytes of your selected maps.

Nota: Ao seleccionar as áreas dos mapas a instalar, o
software de navegação constrói um mapa juntando
todas as áreas.  Se desejar juntar mais áreas
posteriormente, o software de navegação terá de
reconstruir todo o mapa; por isso terá de seleccionar
todos os mapas que escolheu anteriormente para além
do mapa que pretende acrescentar.

14

Carregamento dos mapas
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Método 1 - Por região:
Com esta opção, pode instalar
mapas para todo um estado.  Se o
estado que escolheu tiver um sinal
“+”, isto significa que pode optar por
instalar apenas algumas partes
desse estado (tal como mostra a
figura abaixo).  Para carregar o mapa
de todo um estado, basta certificar-
se de que todas as caixas por baixo
do sinal “+” estão assinaladas.

Depois de seleccionados todos os
mapas pretendidos, clique em Criar
mapa “Generate map” para iniciar a
instalação do mapa.

2. Alternativamente, se o seu computador/
agenda electrónica tiver um espaço de
armazenamento limitado, pode carregar os

Carregamento dos mapas



Método 2 - Por cidade:

Comece por escolher uma região
(um estado) para o mapa
pretendido.  De seguida,
seleccione a cidade e o raio no
mapa no qual pretende utilizar o
sistema de GPS.

Em Local de destino (Target
Location), especifique o local para
onde pretende carregar os mapas.
Quando estiver pronto para iniciar

16

mapas utilizando a opção Por
cidade (By City).

a instalação do mapa, clique em Criar
mapa (Generate Map).

Carregamento dos mapas



O software de instalação inicia a
instalação dos seus mapas.

17

3.

Carregamento dos mapas
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Dependendo das selecções feitas,
pode ser-lhe pedido que introduza o
CD que contém os dados
cartográficos.  Introduza o CD em
questão e clique em OK para
prosseguir.

Nota:  Seja paciente uma vez que a
instalação de um mapa pode
demorar até 30 minutos,
dependendo do tamanho dos
mapas a serem carregados.

4.

Carregamento dos mapas
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Quando a instalação estiver
concluída, verá uma janela como esta:

5.

Carregamento dos mapas
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Lista de verificação

Antes de prosseguir, verifique o seguinte:

• A unidade Bluetooth está ligada e com uma boa visibilidade a céu aberto
• Certifique-se de que tem o software de navegação instalado no dispositivo
• Certifique-se de que instalou todos os mapas pretendidos

Configuração do software
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Estabeleça uma ligação através da
porta série Bluetooth entre o seu
computador/agenda electrónica e a
sua unidade de GPS Bluetooth, tal
como se descreve no “Guia de
instalação rápida do hardware.”  Se
não efectuar esta ligação, o software
não conseguirá encontrar a unidade
de GPS.

Vá até à pasta Programas
(Programs) existente na sua agenda
electrónica e prima o ícone do mapa
aí existente para carregar o software
de navegação.

1.

2.

Configuração do software



Aquando do arranque, é
apresentada uma mensagem de
aviso relativa às etapas a seguir
para garantir a sua segurança
durante a utilização do
equipamento GPS.  Basta clicar em
OK para continuar.

3.
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Configuração do software



4. Se já estabeleceu a sua posição
através do GPS, o mapa
apresentará a sua localização
actual.  Caso contrário, apenas
será apresentada a última
localização conhecida.

23

Configuração do software
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Os ícones visíveis no ecrã permitem-lhe alterar rapidamente as definições
utilizadas com maior frequência ao nível do seu software de navegação.

Permite-lhe activar/desactivar os comandos falados

Permite-lhe introduzir um destino, alterar o ângulo de visualização do
mapa, alterar o percurso/opções de visualização, definir o alerta de
velocidade, gravar informação sobre o percurso, ajustar o volume e
visualizar a informação GPS.

Visualizar a informação GPS

Alterar a sua orientação

Configuração do software
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Na parte inferior do ecrã, existem três
menus à sua escolha: Ficheiro (File),
Ferramentas (Tools) e Menu (Menu).
Para uma explicação mais detalhada
destes menus, consulte a página 41.

Configuração do software



A primeira coisa a fazer é configurar
o software de navegação para que
este detecte a unidade de GPS
Bluetooth.  Para o fazer, clique em
Ferramentas (Tools) e vá até
Opções GPS (GPS Options).

5.
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Configuração do software



Seleccione Detectar
automaticamente (Auto Detect).

6.
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Configuração do software



O software de navegação inicia a
operação de detecção da sua
unidade de GPS.  Basta clicar em
OK para iniciar a operação de
pesquisa.

7.
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Configuração do software



Nesta etapa, se a sua agenda
electrónica não tiver estabelecido uma
ligação com o seu sistema GPS
Bluetooth, pode obter uma janela onde
são apresentados todos os dispositivos
Bluetooth ao seu alcance.  Se tal for o
caso, seleccione o GPS Bluetooth e
clique em OK.  No entanto, se após
várias tentativas o software de
navegação não conseguir encontrar o
seu sistema de GPS, certifique-se de
que seguiu o procedimento descrito no
Guia de instalação rápida do hardware
para estabelecer uma ligação de porta
série entre o seu dispositivo e a
unidade de GPS.

8.
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Configuração do software



Pode também ser-lhe pedido que
introduza uma senha ou código PIN.  Se
tal acontecer, introduza “0000” (quatro
zeros) e de seguida clique em OK.

30

Configuração do software



9. Quando o software detectar o seu
sistema de GPS, basta clicar OK para
confirmar as definições.
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Configuração do software
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Configuração do software



Após estabelecida a ligação →→→→→
unidade de GPS, poderá visualizar
o mapa.  Passe →→→→→ secção seguinte
“Verificar a ligação ao satélite
GPS.”

10.
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Configuração do software



A etapa seguinte consiste em verificar
se a unidade de GPS estabeleceu a
sua posição.  Para tal, clique em Ver >
Informação GPS (View > GPS Info).

1.
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Verificar ligação ao satélite GPS



Se a unidade de GPS tiver
estabelecido a sua posição, verá algo
semelhante à janela seguinte.  As
barras verdes indicam os satélites aos
quais a unidade de GPS está ligada.
As barras vermelhas indicam que não
foi estabelecida ligação a um satélite
específico.  Para poder utilizar o
sistema de GPS, terá de estar ligado
a pelo menos três (3) satélites.

2.

Posição GPS estabelecida:

Neste caso, pode ver que a unidade
de GPS está ligada a 5 satélites dos 8
disponíveis:
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Verificar ligação ao satélite GPS



Posição GPS desconhecida:

Neste caso, pode ver que a unidade
de GPS não estabeleceu a sua
posição GPS e não está ligada a
nenhum satélite (indicado pelas
barras vermelhas).

36

Verificar ligação ao satélite GPS



Se a sua unidade de GPS tiver
problemas no estabelecimento de
ligações aos satélites, experimente o
seguinte:

• Mova a unidade de GPS para
longe de quaisquer edifícios/
estruturas altos

• Mova a unidade de GPS para
longe de quaisquer objectos
que possam interferir com os
sinais sem fios

• Coloque a unidade de GPS
num local com boa visibilidade
a céu aberto (preferencialmen-
te, ao ar livre)

37

Verificar ligação ao satélite GPS



Visualização dos mapas

1.  a sua posição actual
2.  próxima rua onde deve virar
3.  virar nesta direcção
4.  milhas até chegar ao destino

38

Introdução – Primeiros passos

1

23

4



Ícones de atalho

Como pode ver na imagem acima, existem uma série de ícones de atalho no seu
ecrã que lhe permitem aceder facilmente às tarefas mais comuns associadas ao
seu software de navegação.  Para aceder a todas as capacidades do software,
clique nos menus Ficheiro (File), Ferramentas (Tools) e Ver (View) existentes
na parte inferior do ecrã (explicados mais à frente no manual).

39

Introdução – Primeiros passos



Permite-lhe ligar/desligar o som do sistema de navegação

Permite-lhe ver informação sobre o estado do sistema de GPS

Permite-lhe alterar a orientação do mapa

40

Na secção seguinte, explicaremos resumidamente a natureza destas funções e
sua utilização.

: Prima o sinal mais para aplicar mais zoom a uma área
: Prima o sinal menos para aplicar menos zoom a uma área

Introdução – Primeiros passos



Estado GPS: Ligado aos satélites

Estado GPS: A tentar nova ligação

Estado GPS: Não está ligado a um número suficiente de satélites

41

Ícones de estado da unidade de GPS

Estes ícones são apresentados na área do mapa e representam o seguinte:

Introdução – Primeiros passos



Apresenta a área circundante do destino seleccionado no mapa

Apresenta a sua posição actual no mapa

Para definir um endereço como Favorito, clique neste botão

42

Opções do mapa

Estes ícones permitem-lhe fazer o seguinte:

Introdução – Primeiros passos



Se quiser ver as áreas em redor da sua
posição actual no mapa, utilize a
capacidade para visualização
panorâmica.  Para o fazer, prima a
caneta sobre o ecrã da agenda
electrónica e mantenha-a premida sobre
o mapa deslocando-a na direcção que
pretende ver, de seguida liberte a caneta.
O mapa passará então a mostrar esse
local.  Para sair deste modo e voltar à
sua posição actual, clique no X vermelho
existente no canto inferior direito do ecrã.

43

Visualização panorâmica do mapa

Introdução – Primeiros passos



Se premir a caneta sobre o ícone
Menu, poderá aceder ao menu
principal mostrado a seguir.

44

Introdução – Primeiros passos



1.  Introduzir destino (Enter Destina-
tion) (Menu Ficheiroà Introduzir destino
(File Menu → Enter Destination))
Esta opção permite-lhe definir um local e
fornece-lhe instruções quarteirão a
quarteirão.  Como pode ver no menu em
baixo, existem várias formas para definir
um destino.

Dar-lhe-emos alguns exemplos como
referência.  Se continuar a precisar de
ajuda, utilize o menu Ajuda (Help)
existente no software de navegação indo
até Ficheiro à Ajuda (File → Help).

O MENU FICHEIRO (FILE)

45

Parte I – O menu Ficheiro (File)



A. Definir destino - Endereço (Set
Destination – Address)
Ao seleccionar a opção Endereço
(Address), são-lhe apresentadas as
duas opções seguintes:

Rua (Street First) – A utilização desta
opção proporciona um maior número de
resultados mas é muito útil caso esteja
com dificuldades em encontrar um
determinado endereço
Cidade (City First) – Esta opção é muito
útil porque limita o número de resultados
da pesquisa à cidade que especificar
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Parte I – O menu Ficheiro (File)
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Parte I – O menu Ficheiro (File)



Rua (Street First)
Introduza o nome da rua e clique no
botão OK verde.

48

Parte I – O menu Ficheiro (File)



Agora, introduza o número da casa
pretendida, tendo em atenção o
intervalo permitido.  De seguida, clique
no botão OK verde para prosseguir.
Nota: Se o seu endereço estiver fora
do intervalo apresentado, é porque
provavelmente não tem o mapa
necessário para a área.  Isto pode
acontecer caso tenha carregado os
mapas através da opção “Por cidade”
(By city).  Se for este o caso, carregue
uma área maior para o seu mapa ou
seleccione a opção “Por região” (By
region) ao carregar o mapa.
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Parte I – O menu Ficheiro (File)



O software de navegação apresentará
uma lista dos endereços
correspondentes.  Como já
mencionámos, a utilização da opção
Rua (Street first) fornece um maior
número de resultados.  Seleccione o
endereço pretendido e clique em OK no
canto superior direito.
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Parte I – O menu Ficheiro (File)



Cidade (City First)
Introduza o nome da cidade e clique no
botão OK verde.
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Parte I – O menu Ficheiro (File)



De seguida, introduza o nome da rua e
clique em OK.
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Parte I – O menu Ficheiro (File)



Introduza o número da casa, tendo em
atenção o intervalo especificado.
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Parte I – O menu Ficheiro (File)



O software de navegação apresenta
os endereços correspondentes
encontrados.  Como pode ver a seguir,
a opção Cidade (City first) ajudou a
reduzir o número de resultados.
Seleccione o endereço pretendido e
clique em OK no canto superior
direito.
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Parte I – O menu Ficheiro (File)



B. Definir destino - Cruzamento (Set
Destination – Intersection)
Com esta opção, pode introduzir o
nome de duas ruas que se cruzem
como destino

Rua (Street First)
Não recomendamos a utilização desta
opção para localização de um
cruzamento, porque na maior parte
das vezes o número de resultados
apresentado é excessivo.  No entanto,
se apenas carregou uma pequena
parte do mapa no seu dispositivo, já
não terá este problema.
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Introduza o nome da primeira rua e clique
em OK.

Parte I – O menu Ficheiro (File)
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Parte I – O menu Ficheiro (File)



Como pode ver, é apresentado um
grande número de resultados.  Clique
em OK para experimentar com a
opção Cidade (City first).
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Parte I – O menu Ficheiro (File)



Cidade (City First)
Introduza o nome da rua e clique em
OK.
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Parte I – O menu Ficheiro (File)



Introduza o nome da primeira rua e
clique em OK.
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Parte I – O menu Ficheiro (File)



Introduza o nome da segunda rua e
clique em OK.
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Parte I – O menu Ficheiro (File)



Neste caso, o software de navegação
encontrou correspondência para o
cruzamento em questão para além
de que a utilização da opção Cidade
(City first) ajudou a reduzir o número
de resultados para apenas uma
correspondência.  Basta clicar em OK
no canto superior direito para
visualizar o mapa.
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Parte I – O menu Ficheiro (File)



C. Definir destino - Centro da cidade
(Set Destination - City Center)
Esta opção permite-lhe encontrar os
centros das cidades na sua área.

Como exemplo, vamos escolher a opção
Alfabética (Alphabetical).
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Parte I – O menu Ficheiro (File)



Introduza o nome da sua cidade e
clique em OK
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Parte I – O menu Ficheiro (File)



De seguida, clique no botão OK no
canto superior direito.  Se clicar no
botão Nav na parte inferior do ecrã, o
software de navegação apresentará um
mapa do seu local de destino.

64

Parte I – O menu Ficheiro (File)



D. Definir destino - Pontos de
interesse (Set Destination – Points
of Interest)

O software de navegação dispõe de
uma capacidade muito útil designada
de Pontos de interesse (Points of
Interest ou POI).  Como pode ver na
imagem em baixo, estes pontos de
interesse estão classificados por
categorias para um fácil acesso.

Como exemplo, iremos escolher a
opção Atração (Attraction).
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Em Atração (Attraction) encontramos as
sub categorias listadas em baixo.
Vamos escolher Parque de diversões
(Amusement Park) para o nosso
exemplo.
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Proceda à selecção na lista seguinte.
Vamos escolher a opção Alfabética
(Alphabetical) para vermos todos os
parques de diversão existentes próximo
da nossa área.
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Faça a sua selecção na lista seguinte
e de seguida clique em OK
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Para visualizar o mapa do seu ponto de
interesse, clique em OK no canto superior
direito.  Alternativamente, pode clicar no
ícone Nav ou Map na parte inferior do
ecrã.
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E. Definir destino - Favoritos (Set
Destination – Favorites)

Para escolher um destino que tenha já
sido introduzido como um Destino
favorito, clique nesta selecção.  Faça a
sua selecção a partir da lista
apresentada e clique no ícone Nav ou
Map existente na parte inferior do
ecrã.  Nota: Pode editar ou eliminar
uma entrada nesta janela clicando
no ícone Edit ou Del
respectivamente.
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F. Definir destino - Recente (Set
Destination - Recent)

Uma vez que todos os destinos
recentes utilizados estão
armazenados neste local,  se quiser
definir um deles como destino, basta
seleccioná-lo na lista seguinte e clicar
no ícone Nav ou Map na parte inferior
do ecrã para ver o mapa.
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2.  Guardar localização actual (Save
Current Location) (Ficheiro  Guardar
localização actual (File  Save Current
Location)) – esta opção permite-lhe
guardar a sua localização actual no
mapa.  Esta localização será guardada
na sua pasta Favoritos (Favorites).
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3.  Cancelar percurso (Cancel Route)
(Ficheiro → Cancelar percurso (File →
Cancel Route)) – Utilize esta opção
para cancelar um percurso que tenha
introduzido.
Sugestão: Para verificar se o percurso
foi eliminado, clique em Ver → Lista de
percursos (View → Route List), a qual
deve mostrar uma janela vazia como
esta:
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4.  Gravar percurso (Record Track)
(Ficheiro →Gravar percurso (File →
Record Track)) - Para gravar a sua
viagem, clique em Gravar percurso
(Record track) para ver a janela
seguinte.  Introduza a informação
pedida e de seguida clique em OK
para iniciar a gravação.

75

Parte I – O menu Ficheiro (File)



5.  Reproduzir percurso (Play Track)
(Ficheiro → Reproduzir percurso (File →
Play Track) – esta opção reproduz o
percurso anteriormente gravado
Para reproduzir um percurso gravado,
clique em Reproduzir percurso (Play
track) e seleccione o ficheiro que
pretende reproduzir.  Sugestão: Para
parar a reprodução do percurso, clique
em Ficheiro  → Parar percurso (File →
Stop Track).
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6.  Iniciar demonstração (Start
Demo) (Ficheiro → Iniciar
demonstração (File → Start Demo))
Uma das mais úteis capacidades do
software de navegação é a opção
Demonstração (Demo), a qual lhe
permite visualizar uma demonstração
do percurso para um destino específico.
Esta capacidade é muito útil caso
necessite de ajustar/alterar as
definições na sua agenda electrónica
antes de iniciar a condução.
Sugestão:  Se premir o botão Iniciar
demonstração (Start Demo) e nada
acontecer, tenha em atenção de que

é necessário especificar primeiro
um destino.
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7.  Acerca do sistema de navegação
(About Navigation System) (Ficheiro
→ Acerca do sistema de navegação
(File → About Navigation system)) –
esta opção apresenta uma janela com
informação acerca do software
cartográfico
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8.  Ajuda (Help) (Ficheiro → Ajuda
(File → Help)) – esta opção
apresenta o conteúdo da ajuda
interna do software de navegação.
Esta é uma capacidade muito útil
caso necessite de uma explicação
rápida sobre como executar
determinadas tarefas ao nível do
software de navegação.
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9.  Sair (Exit) (Ficheiro → Sair (File →
Exit)) – esta opção permite-lhe sair do
programa e descarrega o mesmo da
memória da sua agenda electrónica
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1.  Normas de segurança (Safety
Features) (Ferramentas →Normas de
segurança (Tools → Safety Features)) –
ajudam-no a tornar a sua condução mais
segura .

Alerta de velocidade (Speed Alert)
Se desejar receber um alerta sonoro
sempre que atingir uma determinada
velocidade limite, active o alerta de
velocidade.  Se definir esta opção para
Auto (Auto), o software de navegação
determina o limite de velocidade com base

O MENU FERRAMENTAS (TOOLS)

Parte II - O menu Ferramentas (tools)
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no tipo de estrada em que se encontra
(rua, via rápida, etc.)  No entanto, este
alerta existe apenas para lhe facilitar a
condução não existindo qualquer
garantia relativamente à sua precisão.
Recomendamos-lhe que cumpra todos
os limites de velocidade, que respeite
as normas de trânsito e que utilize o
seu bom senso ao usar esta
capacidade.

Condução com nevoeiro (Fog Driving)
Se activar esta opção, o software
notificá-lo-á da aproximação de um
cruzamento.
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2.  Unidades de distância (Distance
Units) (Ferramentas → Unidades de
distância (Tools → Distance Units)) -
esta opção permite-lhe alterar as
unidades de distância apresentadas
pelo seu software de navegação.
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83



3.  Opções de percurso (Route
Options) (Ferramentas → Opções de
percurso (Tools →Route Options)) –
personalize o software para que este
lhe dê instruções com base nas suas
preferências.  Segue-se uma breve
descrição destas definições.  Para mais
informações, utilize o menu Ajuda
(Ficheiro → Ajuda (File → Help))
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Método (Method)
Mais rápido (Quickest) – Esta opção
fornece-lhe informações que lhe
permitem chegar ao seu destino mais
rapidamente (por exemplo, utilizando
as vias rápidas para viagens longas
evitando assim as congestionadas
estradas locais)

Mais curto (Shortest) – Esta opção
fornece-lhe informações com base no
percurso mais curto em termos da sua
distância física (pode não ser a opção
mais rápida)

Principal (Major) – Esta opção dá-lhe
informações tendo por base as
estradas principais (se não quiser
andar perdido em estradas
desconhecidas)

Local (Local) – Esta opção fornece-lhe
apenas informações tendo por base as
estradas locais (evita as vias rápidas)
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4.  Opções de visualização (Display
Options) (Ferramentas → Opções de
visualização (Tools → Display Options))
Segue-se uma breve descrição destas
definições.  Para mais informações,
utilize o menu Ajuda (Help) (Ficheiro →
Ajuda (File → Help))
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Orientação do mapa (Map
Orientation) – Altere esta definição
tendo por base a sua orientação para
uma melhor visualização do mapa

Esquema de cores (Color Scheme)
Auto (Auto) – altera o esquema de
cores do ecrã para visualização
diurna/nocturna ao nascer e pôr do
sol, respectivamente.
Diurna (Day) – o ecrã encontra-se no
modo de visualização normal para
visualização diurna
Nocturna (Night) – o plano de fundo
do mapa escurece e as linhas que
assinalam as estradas ficam mais

claras para uma melhor visualização

Ecrã de orientação (Guidance Screen)
– se esta opção estiver definida para
Auto (Auto) o mapa é ampliado quando
se estiver a aproximar da área, caso
contrário terá de clicar na área
manualmente.
Ícones POI (POI Icons) – se esta opção
estiver activada (On), serão
apresentados ícones no mapa caso a
sua condução esteja a ser feita com
base nos pontos de interesse
assinalados na base de dados
cartográfica.
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Ver mapa em 3D (3D Map View) –
pode alterar a forma de visualização
do mapa para o modo 3D para uma
visualização mais realista do mesmo

5.  Opções de atalho (Hotkey Options)
(Ferramentas → Opções de atalho
(Tools → Hotkey Options)) – esta opção
permite-lhe atribuir uma tarefa
específica a um botão da sua agenda
electrónica
Esta é uma capacidade muito útil do
software uma vez que lhe permite
atribuir uma tarefa específica a qualquer
um dos botões da sua agenda
electrónica para que possa executar
funções ao nível do software de
navegação com o simples premir de um
botão.
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Para tal, basta seleccionar uma função
da lista e clicar no botão da sua agenda
electrónica que pretende atribuir a esta
função.  Após esta operação, deverá
ver o botão # no separador designado
como “Botão” (Button).  Se quiser
anular esta selecção, clique em Limpar
botão (Clear Key) para limpar a função
seleccionada ou clique em Limpar
todos (Clear All) para limpar todas as
funções atribuídas aos botões.

As funções que podem ser atribuídas
aos botões de uma agenda
electrónica são:

Modo 3D (3D Mode)
Posição actual (Current Position)
Personalizar ícones POI (Customize
POI Icons)
Desvio (Detour)
Opções de visualização (Display
Options)
Introduzir destino (Enter Destination)
Ecrã inteiro (Fullscreen)
Informação GPS (GPS Info)
Menu (Menu)

Parte II - O menu Ferramentas (tools)
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Cortar o som (Mute)
Norte/Para cima (North/Heading Up)
Activar/Desactivar ícones POI (POI
Icons On/Off)
Lista de percursos (Route List)
Opções de percurso (Route Options)
Alerta de velocidade (Speed Alert)
Volume (Volume)

6.  Opções de introdução (Input
Options) (Ferramentas → Opções de
introdução (Tools → Input Options)) –
estas opções permitem-lhe definir a
forma como a informação é introduzida
no sistema de navegação

Teclado do Pocket PC (Pocket PC
Keyboard) – toda a informação
introduzida pelo utilizador terá de ser
introduzida através do teclado virtual da
agenda electrónica
(neste caso, premindo o ícone de
teclado que vê no canto inferior direito
da imagem em baixo).
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Teclado do sistema de navegação
(Navigation System Keyboard) – esta
opção permite a introdução da
informação através do teclado interno
do software de navegação.  Esta
é uma opção melhor uma vez que as
teclas são apresentadas em tamanho
maior na agenda electrónica, podendo
utilizar na mesma o teclado do Pocket
PC se o desejar.
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7.  Opções GPS (GPS Options)
(Ferramentas → Opções GPS (Tools →
GPS Options)) – para selecção manual
das definições para a sua unidade de
GPS ou para definição da opção
Detectar automaticamente (Auto Detect)

Nota: O número da porta COM é o número da porta de
saída COM que o seu computador/agenda electrónica
utiliza para ligar à unidade de GPS.  Defina esta opção
manualmente apenas se não tiver dúvidas quanto à
porta COM utilizada pelo seu PC/agenda electrónica.

Parte II - O menu Ferramentas (tools)
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O MENU VER (VIEW)

Part III - O menu  Ver (View)
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1.  Mapa (Map) (Ver → Mapa (View →
Map)) -leva-o de volta à janela de
visualização do mapa

2.  Orientação (Guidance) (Ver →
Orientação (View → Guidance)) -
Amplia a sua posição actual e informa-o
da próxima manobra (ex: virar →
esquerda/direita).
Sugestão: Por predefinição, isto é feito
automaticamente pelo sistema de
navegação.  Se quiser alterar esta
situação, vá até: Ferramentas à Opções
de visualização à Ecrã de orientação à
Auto/Manual (Tools → Display Options
→ Guidance Screen à Auto/Manual).

Part III - O menu  Ver (View)
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3.  Lista de percursos (Route List)
(Ver → Lista de percursos (View →
Route List)) – apresenta instruções
textuais sobre como chegar ao seu
destino

Part III - O menu  Ver (View)
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4.  Informação GPS (GPS Info) (Ver →
Informação GPS (View → GPS Info)) –
esta opção apresenta informação sobre
o estado do GPS bem como outras
informações úteis

Hora UTC (UTC Time) – Tempo
Universal Coordenado
Hora local (Local Time) – A hora na sua
área

Na opção Localização (Location),
pode também ver a sua Latitude,
Longitude e Altitude.

NMEA - National Marine Electronics
Association.  Esta janela apresenta
alguma da informação recebida pela
unidade de GPS.

Part III - O menu  Ver (View)
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Part III - O menu  Ver (View)
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5.  Almanaque (Almanac) (Ver →
Almanaque (View → Almanac)) –
apresenta informação relativa ao Sol/à
Lua

Part III - O menu  Ver (View)
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6.  Ampliar/Reduzir (Zoom in/Zoom
out) (Ver à + Zoom/- Zoom (View à
Zoom +/Zoom -)) – clique nesta
opção para ampliar/reduzir uma
área.  Alternativamente, pode
também utilizar os ícones azuis +/-
existentes na parte inferior do mapa.
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Para uma lista mais completa dos problemas e sua resolução/Perguntas
frequentes, consulte as secções Resolução de problemas (Troubleshooting) e
Perguntas frequentes (Frequently Asked Questions) no software de navegação
(Ficheiro à Ajuda (File à Help)).

1.  Durante a instalação dos mapas, obtenho uma mensagem de erro
relacionada com a gravação dos ficheiros.
Isto pode dever-se a espaço insuficiente na memória no seu computador/agenda
electrónica.  Instale os mapas num outro local ou instale mais memória no seu
dispositivo.

2.  O meu sistema de GPS Bluetooth da IOGEAR não consegue estabelecer
a posição.
Certifique-se de que a unidade se encontra no exterior, longe de edifícios ou
estruturas altas ou de quaisquer objectos que possam causar interferências.

Resolução de problemas
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Certifique-se também de que a unidade de GPS está totalmente carregada (o
carregamento completo demora cerca de 3 horas).

Se mesmo assim não conseguir estabelecer a posição, faça a reposição da
unidade de GPS tal como se descreve no Guia de instalação rápida do
hardware.

3.  A minha agenda electrónica não responde ou fica muito lenta após
carregar o sistema de navegação.
Em primeiro lugar, certifique-se de que a sua agenda electrónica satisfaz os
requisitos mínimos do sistema.  Pode também aproveitar para verificar todos os
programas em execução na sua agenda electrónica.  Se tiver muitos programas
em execução em segundo plano, estes podem estar a consumir a memória do
sistema e assim tornar a sua agenda electrónica mais lenta.

Resolução de problemas
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4.  O software de navegação não é carregado para o meu PC/agenda
electrónica.
Certifique-se de que a sua agenda electrónica satisfaz os requisitos mínimos do
sistema.

5.  Estou com problemas em estabelecer a comunicação Bluetooth entre o
meu PC/agenda electrónica e a unidade de GPS.
Consulte o Guia de instalação rápida do hardware para mais instruções sobre
como estabelecer a comunicação.  Se continuar com problemas, consulte o
Manual do utilizador do seu dispositivo Bluetooth.

Resolução de problemas
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Especificações
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Especificações
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Assistência técnica

Se você ainda tiver problemas depois de ler o Manual do usuário do produto e a
seção Solução de problemas, entre em contato com o suporte técnico pelo
telefone: 1-949-453-8782 ou, simplesmente visite o site da empresa em
www.iogear.com e verifique se há versões mais recentes ou outras informações
sobre o produto e/ou software.
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Declaração de interferência em rádio e TV

AVISO!!! Este equipamento gera, usa e pode irradiar energia de radiofreqüência
e, se não for instalado e usado de acordo com o manual de instruções, poderá
causar interferência em comunicações de rádio. O equipamento foi testado e
aprovado como compatível com os limites para dispositivos de computação da
Classe B de acordo com os termos da Subparte J da Parte 15 das normas da
FCC, criados para oferecer proteção contra esse tipo de interferência durante a
operação em ambiente comercial. A operação deste equipamento em área
residencial pode causar interferência. Nesse caso, o usuário, às suas próprias
custas, deverá tomar as providências necessárias para corrigir a interferência.
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EM HIPÓTESE ALGUMA A RESPONSABILIDADE DIRETA DO FORNECEDOR
DEVERÁ EXCEDER O PREÇO PAGO PELO PRODUTO, SE OCORREREM
DANOS DIRETOS, INDIRETOS, ESPECIAIS, ACIDENTAIS OU
CONSEQÜENTES, RESULTANTES DO USO DO PRODUTO, CD OU DE SUA
DOCUMENTAÇÃO.

O fornecedor direto não concede garantias nem representações, expressas,
implícitas ou legais, em relação ao conteúdo ou ao uso desta documentação, e
não se responsabiliza por sua qualidade, seu desempenho, sua comercialização
ou sua adequação para fins específicos.

O fornecedor direto também se reserva o direito de revisar ou atualizar o
dispositivo ou a documentação, sem a obrigação de notificar qualquer pessoa ou
entidade de tais atos. Para maiores esclarecimentos, consulte o fornecedor
direto.

Garantia limitada
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Informações para contato.




