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Willkommen

Danke für den Kauf der Bluetooth-GPS-Systems von IOGEAR.  Dieses Bluetooth-GPS-
System ist ein Echtzeit-Navigationssystem. Mit dem Bluetooth-GPS-Empfänger erhalten
Sie Positionierungsdaten von Satelliten und senden Daten über Bluetooth drahtlos zu
mobilen Computergeräten. Er verfügt über positionsgetreue Genauigkeit und äußerst
zuverlässige Routenverfolgung. Für wenig Energieverbrauch entwickelt und zusammen
mit einer langlebigen, wiederaufladbaren Batterie erhalten Sie 30 Stunden kontinuierliche
Benutzung, was ständiges Wiederaufladen zwischen einzelnen Nutzungsphasen
überflüssig macht. Das Gerät ist tragbar und leicht, so dass Sie es auf dem Armaturenbrett
oder an einer anderen Stelle ablegen können, vorausgesetzt, eine direkte Sichtlinie zum
Himmel ist gegeben.

Sie werden sich nie wieder verirren!
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Systemanforderungen

Laptop/Desktop:

Windows ME/2000/XP
Mindestens 256 MB freier Systemspeicher und mindestens 512 MB freier
Festplattenspeicher
Muss Bluetooth-aktiviert sein und ein serielles Anschlussprofil unterstützen

PDA (Pocket PC):

Microsoft Pocket PC 2002 oder neuere Version erforderlich
PDA mit mindestens einem 266-MHz-Prozessor und mindestens 64 MB freiem
Hauptspeicher
Speicherkarte mit mindestens 64 MB zum Laden zusätzlicher Karten ist
empfehlenswert
Muss Bluetooth-aktiviert sein und ein serielles Anschlussprofil unterstützen
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Softwarefunktionen

• Sprachanweisungen vor jeder Abbiegung helfen Ihnen, Ihre Aufmerksamkeit auf die
Straße zu richten

• Automatische Richtungsanweisungen helfen Ihnen, zu Ihrem Ziel zu kommen, auch
wenn Sie falsch abgebogen sind

• Schnellste, kürzeste, lokale, wichtigste und fahrgemeinschaftliche Routenoptionen

• Bildschirm mit automatischen Manövrieranweisungen

• Kartenanzeige in Echtzeit

• Automatisches Vollbild

• Detaillierte Kartenanzeige mit Straßennamen

• Automatisches Farbschema für Tag und Nacht

• 3-D-Vogelperspektive

• Hotkey-Optionen für Befehlsabkürzungen über Ihre PDA-Tasten
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• Sonderfunktionen für Tempo- und Nebelwarnungen

• Datenbank mit großen, interessanten Orten

• Bevorzugte und kürzlichen Ziele

• Einfach abrufbares Statusfeld, das voraussichtliche Ankunftszeit, Entfernung und
Tempo anzeigt

• Aufnahme und Wiedergabe einer Route

• Demo-Modus mit Fahrsimulation Ihrer Reise

• Navteq-Kartendatenbank

Softwarefunktionen
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Softwareinstallation

Checkliste
Prüfen Sie Folgendes, bevor Sie fortfahren:

• Diese Anleitung setzt voraus, dass Microsoft ActiveSync bereits installiert und für
Datenübertragung zwischen dem PDA und dem Computer konfiguriert ist.

• Schließen Sie den PDA über seine Cradle oder das Synchronisierungskabel an den
Computer an
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Softwareinstallation

Installieren der Software

1.  Legen Sie die Setup-Installations-CD
ein, die im Produktkarton enthalten ist.  Die
CD startet automatisch und beginnt mit der
Installation.

2. Der Installationsassistent zeigt
nachstehendes Fenster an.  Klicken Sie
auf Weiter (Next), um den Vorgang
fortzusetzen.
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3.  Wenn Sie den Lizenzvertrag
akzeptieren, klicken Sie auf Ja
(Yes).

Softwareinstallation
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Softwareinstallation

4.  Im nächsten Fenster können Sie
die Version der Navigationssoftware
aussuchen, die Sie installieren
möchten.  Treffen Sie nachstehend
Ihre Wahl und klicken Sie dann auf
Weiter (Next).
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Softwareinstallation

5. Warten Sie einige Augenblicke,
denn die Installationsdateien
werden jetzt zum Computer
übertragen.
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6.  Wenn Sie das Feld “Pocket PC”
anwählten, wird eine Eingabeaufforderung
angezeigt, ähnlich der folgenden Abbildung.
Wenn Sie das Programm im Hauptspeicher
Ihres PDA installieren möchten, klicken Sie
auf Ja (Yes).

Möchten Sie die Navigationssoftware
jedoch anderswo installieren, klicken Sie
auf Nein (No).  Es wird dann ein Fenster
angezeigt, in dem Sie angeben können, wo
die Programmdateien installiert werden
sollen.  Treffen Sie Ihre Wahl und klicken
Sie dann auf OK.

Softwareinstallation



15

7.  Die Software bereitet die Dateien vor,
die auf dem PDA installiert werden.

8. Prüfen Sie Ihren PDA, ob weitere Schritte
für eine abschließende
Programminstallation benötigt werden.

Softwareinstallation
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9.  Klicken Sie auf Fertig stellen
(Finish), um die Installation zu
beenden, und fahren Sie mit dem
nächsten Abschnitt fort.

Softwareinstallation
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Laden von Karten

Laden von Karten

10.  Ist die Kartensoftware geladen, können
Sie die Karten aussuchen, die Sie auf Ihrem
Gerät installieren möchten.  Es gibt zwei
Möglichkeiten, Karten zu installieren – nach
Region oder nach Stadt.  Ist weniger als 64
MB Speicher verfügbar, wird empfohlen, die
Karten “Nach Stadt” (By City) zu installieren.
Verfügen Sie jedoch über einen
ausreichenden Speicher, können Sie die
Karten mit der Option Nach Region (By
Region) installieren.

Auf der rechten Bildschirmseite können Sie
den Zielstandort (Target Location) wählen,

wo Sie die Karten laden möchten (auf dem
PDA oder dem Computer).  Hier wird auch
der verfügbare Speicherplatz auf Ihrem
gewählten Standort und die Größe der
ausgewählten Karten in Megabyte angzeigt.

Hinweis: Bei der Wahl der zu installierenden
Karten erstellt die Navigationssoftware eine Karte,
auf der alle Bereiche zusammengefügt sind.
Wenn Sie später weitere Bereiche hinzufügen
möchten, muss dieNavigationssoftware die
gesamte Karte neu aufbauen; daher müssen Sie
dann alle vorherigen Karten auswählen, plus der
Karte, die Sie hinzufügen.
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Methode 1 – Nach Region (By Region):
Mit dieser Option können Sie Karten für
einen ganzen Bundesstaat installieren.  Ist
der Bundesstaat Ihrer Wahl mit einem “+”-
Zeichen versehen, bedeutet es, dass Sie
den betreffenden Bundesstaat nur in Teilen
installieren können (siehe nachstehende
Abbildung).  Um die Karte für den ganzen
Bundesstaat zu laden, müssen Sie darauf
achten, dass alle Felder einer Ebene
unterhalb des “+”-Zeichens angewählt sind.

Sind alle gewünschten Karten ausgewählt,
klicken Sie auf “Karte erstellen” (Generate
Map), um mit der Karteninstallation zu
beginnen.

Laden von Karten
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Laden von Karten

11.  Verfügt Ihr Computer/PDA jedoch nur
über einen beschränkten Speicherplatz,
können Sie die Karten mit der Option Nach
Stadt (By City) installieren.

Methode 2 – Nach Stadt (By City):

Wählen Sie zuerst eine Region (einen
Bundesstaat) für die gewünschte Karte.
Wählen Sie dann die Stadt (City) und den
Kartenradius (Map Radius), innerhalb dem
Sie das GPS-System verwenden möchten.

Geben Sie unter Zielstandort (Target Lo-
cation) an, wo Sie die Karten laden
möchten.  Wenn Sie bereit sind, die Karte

zu installieren, klicken Sie auf “Karte
erstellen” (Generate Map).
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12.  Die Installationssoftware beginnt jetzt mit
der Installation Ihrer Karten.

Laden von Karten
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Laden von Karten

13.  Je nach Ausgewähltem werden Sie
aufgefordert, die CD einzulegen, auf der sich
Ihre Karte befindet.  Legen Sie die CD ein
und klicken Sie auf OK, um den Vorgang
fortzusetzen.

Hinweis:  Haben Sie bitte etwas Geduld,
denn je nach Größe der zu ladenden Karten
kann die Karteninstallation bis zu 30 Minuten
dauern.
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14.  Sobald die Installation abgeschlossen
ist, sehen Sie ein Fenster ähnlich wie
dieses:

Laden von Karten
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Konfigurieren der Software mit dem GPS-Gerät

Checkliste
Prüfen Sie Folgendes, bevor Sie fortfahren:

• Bluetooth-Gerät ist eingeschaltet und hat eine ungehinderte Sicht zum Himmel

• Your Computer/PDA has established a

• Vergewissern Sie sich, dass die Navigationssoftware auf Ihrem Gerät installiert ist

• Vergewissern Sie sich, dass alle gewünschten Karten installiert sind
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1.  Stellen Sie über den seriellen Anschluss
eine Bluetooth-Verbindung zwischen
Computer/PDA und Ihrem Bluetooth-GPS-
Gerät her, wie in “Hardware-
Schnellstartanleitung”
beschrieben ist.  Wenn Sie diesen Schritt
auslassen, kann die Software das GPS-
Gerät nicht finden.

2.  Wechseln Sie zum Ordner Programme
(Programs) auf dem PDA und tippen Sie auf
das dort befindliche Kartensymbol, um die
Navigationssoftware zu laden.

Konfigurieren der Software mit dem GPS-Gerät



25

3.  Gleich zu Anfang erscheint eine
Warnmeldung mit zu beachtenden
Schritten, um Ihre Sicherheit während
Bedienung des GPS-Geräts nicht zu
beeinträchtigen.  Klicken Sie einfach auf OK,
um den Vorgang fortzusetzen.

Konfigurieren der Software mit dem GPS-Gerät



26

4. Ist die GPS-Position bereits ermittelt, zeigt
die Karte Ihren aktuellen Standort an.
Andernfalls wird der letzte, bekannte
Standort angezeigt.

Konfigurieren der Software mit dem GPS-Gerät
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Mit den Symbolen auf dem Bildschirm können Sie die am häufigsten verwendeten
Einstellungen für die Navigationssoftware schnell ändern.

Schaltet die Lautstärke der Sprechanweisungen bei Abzweigungen EIN/AUS

Dient zur Eingabe eines Ziels, zum Ändern der Kartenansicht und der Routen/
Anzeigeoptionen, zum Einstellen der Tempowarnung, zur Aufzeichnung von
Routendaten, zum Einstellen der Lautstärke und zur Anzeige der GPS-Info.

Zeigt die GPS-Info an

Ändert Ihre Richtung

Konfigurieren der Software mit dem GPS-Gerät
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Es gibt drei Menüoptionen unten im
Bildschirm: Datei (File), Extras (Tools) und
Menü (Menu).  Eine detaillierte Erklärung
und Beschreibung dieser Menüs finden
Sie auf Seite 48.

Konfigurieren der Software mit dem GPS-Gerät
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5.  Zuallererst möchten wir die
Navigationssoftware so konfigurieren, dass
sie das Bluetooth-GPS-Gerät erkennt.
Klicken Sie hierfür auf Extras (Tools) und
gehen Sie herunter zu den GPS-Optionen
(GPS Options).

Konfigurieren der Software mit dem GPS-Gerät
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6.  Klicken Sie jetzt auf Autom. erkennen
(Auto Detect).

42

Konfigurieren der Software mit dem GPS-Gerät
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7.  Die Navigationssoftware ist jetzt bereit,
nach dem GPS-Gerät zu suchen.  Klicken
Sie einfach auf OK, um mit dem
Scanvorgang zu beginnen.

Konfigurieren der Software mit dem GPS-Gerät
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8.  Wenn jetzt noch keine Verbindung
zwischen Ihrem PDA und Ihrem Bluetooth-
GPS hergestellt ist, erhalten Sie ein Fenster,
das alle in Reichweite befindlichen Bluetooth-
Geräte anzeigt.  Wählen Sie in diesem Fall
das Bluetooth-GPS aus und klicken Sie auf
OK.  Wenn die Navigationssoftware auch
nach mehreren Versuchen Ihr GPS nicht
finden kann, prüfen Sie, ob Sie den in der
Hardware-Schnellstartanleitung
aufgeführten Vorgang zur Herstellung
einer seriellen Anschlussverbindung
zwischen Ihrem Gerät und dem GPS-
Gerät durchlaufen haben.

Konfigurieren der Software mit dem GPS-Gerät
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Konfigurieren der Software mit dem GPS-Gerät

Möglicherweise werden Sie auch
aufgeforder t, einen Kennschlüssel
(Passkey) oder einen PIN-Code
einzugeben.  Geben Sie in diesem Fall
“0000” (vier Nullen) ein und klicken Sie dann
auf OK.
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9.  Hat die Software Ihr GPS-Gerät gefunden,
klicken Sie einfach auf OK, um die
Einstellungen zu bestätigen.

Konfigurieren der Software mit dem GPS-Gerät
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Konfigurieren der Software mit dem GPS-Gerät
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10.  Ist eine Verbindung zum GPS-Gerät
hergestellt, wird die Karte angezeigt.
Fahren Sie mit dem nächsten Abschnitt
“Prüfen der GPS-Satellitenverbindung” fort.

Konfigurieren der Software mit dem GPS-Gerät
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Prüfen der GPS-Satellitenverbindung

Prüfen der GPS-Satellitenverbindung

1.  Der nächste Schritt ist, zu überprüfen,
ob das GPS seine Position ermittelt hat.
Klicken Sie hierfür auf Ansicht > GPS-Info
(View > GPS Info).
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2.  Hat das GPS-Gerät seine Position
ermittelt, erscheint ein Fenster ähnlich dem
Folgenden.  Die grünen Balken zeigen die
Satelliten, mit denen das GPS-Gerät
verknüpft ist.  Die roten Balken zeigen an,
dass eine Verknüpfung zum betreffenden
Satelliten nicht hergestellt ist.  Um GPS
verwenden zu können, müssen Sie mit
mindestens drei (3) Satelliten verbunden
sein.

GPS-Position ermittelt:

In diesem Fall sehen Sie, dass das GPS mit
5 von 8 Satelliten verbunden ist:

Prüfen der GPS-Satellitenverbindung
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GPS-Position unbekannt:

In diesem Fall sehen Sie, dass das GPS
seine Position nicht ermittelt hat und mit
keinem Satelliten verknüpft ist (anhand der
roten Balken ersichtlich).

Prüfen der GPS-Satellitenverbindung
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Prüfen der GPS-Satellitenverbindung

Wenn Ihr GPS sich nicht mit Satelliten
verknüpfen kann, versuchen Sie
Folgendes:

• Gehen Sie mit dem GPS weg von
großen Gebäuden/Strukturen

• Gehen Sie mit dem GPS weg von
einem Objekt, dass drahtlose Signale
stören kann

• Stellen Sie das GPS an einem Ort auf,
wo eine klare Sicht zum Himmel
besteht (vorzugsweise im Freien)
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Einführung – Erste Schritte

Kartenansicht
Die nächste
Abzweigung

Meilen bis
zum Zielpunkt

Ihre derzeitige
Position

Entfernung bis zur
nächsten Straße
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Abkürzungssymbole

Wie Sie dem obigen Bild entnehmen können, gibt es mehrere Abkürzungssymbole auf
dem Bildschirm, mit denen Sie die häufigsten Aufgaben ausführen können, die mit der
Navigationssoftware in Bezug stehen.  Um alle Funktionen der Software aufzurufen, klicken
Sie auf die Menüs Datei (File), Extras (Tools) und Ansicht (View) unten im Bildschirm
(werden später im Handbuch erklärt).

Einführung – Erste Schritte
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Hiermit schalten Sie den Sound für das Navigationssystem EIN/AUS

Zeigt GPS-Statusinformationen an

Ändert die Kartenausrichtung

Im folgenden Abschnitt erklären wird kurz jede einzelne dieser Funktionen und ihre
Verwendung.

Einführung – Erste Schritte
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GPS-Status: Mit Satelliten verknüpft

GPS-Status: Es wird versucht, sich neu zu verbinden

GPS-Status: Nicht mit ausreichenden Satelliten verknüpft

Einführung – Erste Schritte

GPS-Statussymbole
Diese Symbole werden auf dem Kartenbereich angezeigt und stellen Folgendes dar:
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Zeigt den umgebenden Bereich des ausgewählten Ziels auf der Karte

Zeigt Ihre aktuelle Position auf der Karte

Klicken Sie auf diese Schaltfläche, um eine Adresse als Favorit einzurichten

Einführung – Erste Schritte

Troublesho··ngKartenoptionen
Mit diesen Symbolen können Sie Folgendes tun:
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Einführung – Erste Schritte

Verschieben der Karte

Wenn Sie den umgebenden Bereich Ihres
aktuellen Standorts auf der Karte sehen
möchten, verwenden Sie die
Schiebefunktion.  Tippen Sie hierfür auf den
PDA-Bildschirm, halten Sie den Stift auf die
Karte gedrückt und schieben Sie ihn in die
Richtung, die Sie sehen möchten, und
setzen Sie den Stift dann wieder ab.  Die
Karte setzt dann den betreffenden Standort
in die Mitte.  Um diesen Modus zu beenden
und zur aktuellen Position zurückzukehren,
klicken Sie auf das rote X in der unteren,
rechten Ecke.
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Beim Tippen auf das Menüsymbol
kehren Sie zum Hauptmenü zurück,
siehe unten

Einführung – Erste Schritte
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Teil I – Menü Datei (File)

1.  Ziel eingeben (Enter Destination) (Menü
Datei (File) ➔ Ziel eingeben (Enter
Destination))
Mit dieser Menüoption legen Sie einen
Standort fest und erhalten
Richtungsanweisungen in Blöcken.  Wie Sie
anhand des folgenden Menüs sehen
können, gibt es mehrere Möglichkeiten, ein
Ziel festzulegen.

Es folgen einige wenige Beispiele als
Referenz.  Benötigen Sie dennoch
Unterstützung, rufen Sie das Hilfemenü der
Navigationssoftware auf, indem Sie Datei
(File) ➔ Hilfe (Help) antippen.
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Teil I – Menü Datei (File)

Ziel einstellen (Set Destination) – Adresse
(Address)
Bei Wahl der Option Adresse (Address)
erhalten Sie wie folgt zwei
Auswahlmöglichkeiten:

Straße zuerst (Street First) – Diese Option
liefert normalerweise mehr Suchergebnisse,
doch ist sie sehr hilfreich, wenn Sie Mühe
haben, eine bestimmte Adresse zu finden

Stadt zuerst (City First) – Diese Option ist
sehr nützlich, denn sie beschränkt die
Suchergebnisse auf die von Ihnen
angegebene Stadt
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Teil I – Menü Datei (File)
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Straße zuerst (Street First)
Geben Sie den Straßennamen ein und
klicken Sie dann auf die grüne OK-
Schaltfläche.

Teil I – Menü Datei (File)
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Teil I – Menü Datei (File)

Geben Sie jetzt die Hausnummer Ihres Ziels
ein, wobei Sie auf den angezeigten
Gültigkeitsbereich achten müssen.  Klicken
Sie dann auf die grüne OK-Schaltfläche, um
fortzufahren.

Hinweis: Fällt Ihre Adresse außerhalb des
angezeigten Bereichs, haben Sie wahrscheinlich
nicht die Karte, die für den betreffenden Bereich
benötigt wird.  Dies könnte der Fall sein., wenn Sie
Karten mit der Option “Nach Stadt” (By City) geladen
haben.  Laden Sie in diesem Fall einen Bereich mit
einem größeren Kartenradius oder wählen Sie beim
Laden der Karte die Option “Nach Region” (By
Region).
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Teil I – Menü Datei (File)

Die Navigationssoftware zeigt jetzt eine Liste
mit übereinstimmenden Adressen.  Wie
bereits erwähnt, liefert die Option “Straße
zuerst” (Street First) normalerweise mehrere
übereinstimmende Adressen.  Wählen Sie
Ihre Adresse und klicken Sie dann oben
rechts auf OK.
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Teil I – Menü Datei (File)

Stadt zuerst (City First)
Geben Sie den Stadtnamen ein und klicken
Sie dann auf die grüne OK-Schaltfläche.
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Geben Sie den Straßennamen ein und
klicken Sie dann auf OK

Teil I – Menü Datei (File)
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Geben Sie die Hausnummer ein, wobei Sie
den angegebenen Bereich beachten
müssen.

Teil I – Menü Datei (File)
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Teil I – Menü Datei (File)

Die Navigationssoftware zeigt die
gefundenen, übereinstimmenden Adressen.
Wie sie nachstehend sehen können, hilft
Ihnen die Option “Stadt zuerst” (City First),
die Suchergebnisse einzuschränken.
Wählen Sie die gewünschte Adresse und
klicken Sie oben rechts auf OK.
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Teil I – Menü Datei (File)

Ziel einstellen (Set Destination) –
Kreuzung (Intersection)
Mit dieser Option können Sie die Namen
von zwei sich kreuzenden Straßen als Ziel
eingeben

Straße zuerst (Street First)
Es ist nicht empfehlenswert, diese Option
für eine Kreuzung zu wählen, da sie
meistens zu viele Ergebnisse liefert.  Haben
Sie jedoch nur einen kleinen
Kartenabschnitt auf Ihrem Gerät geladen,
wird dieses Problem nicht auftreten.
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Teil I – Menü Datei (File)

Geben Sie den ersten Straßennamen ein
und klicken Sie dann auf OK
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Wie Sie sehen, gibt es zu viele
übereinstimmende Ergebnisse.  Klicken Sie
auf OK, um die Option Stadt zuerst (City
First) zu versuchen.

Teil I – Menü Datei (File)
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Teil I – Menü Datei (File)

Stadt zuerst (City First)
Geben Sie den Stadtnamen ein und klicken
Sie dann auf OK
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Geben Sie den ersten Straßennamen
ein und klicken Sie dann auf OK

Teil I – Menü Datei (File)
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Teil I – Menü Datei (File)

Geben Sie den zweiten Straßennamen
ein und klicken Sie dann auf OK
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In diesem Fall fand die Navigationssoftware
eine Übereinstimmung für die Kreuzung,
und die Option “Stadt zuerst” (City First) half
uns, die Suchergebnisse auf nur eine
Übereinstimmung einzuschränken.  Klicken
Sie oben rechts auf OK, um die Karte
anzuzeigen.

Teil I – Menü Datei (File)
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Teil I – Menü Datei (File)

Ziel einstellen (Set Destination) –
Stadtmitte (City Center)

Hiermit finden Sie die Stadtmitten in Ihrem
Gebiet.

Als Beispiel wählen wir die Option
Alphabetisch (Alphabetical).
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Geben Sie den Stadtnamen ein und
klicken Sie dann auf OK.

Teil I – Menü Datei (File)
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Teil I – Menü Datei (File)

Klicken Sie jetzt oben rechts auf die
Schaltfläche OK.  Klicken Sie jetzt unten auf
Nav, zeigt die Navigationssoftware Ihnen
eine Karte vom Ziel.
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Hier ist eine Karte von der in Irvine,
Kalifornien, gefundenen Stadtmitte.

Teil I – Menü Datei (File)



69

Teil I – Menü Datei (File)

Ziel einstellen (Set Destination) –
Interessante Orte (Points of Interest)

Die Navigationssoftware besitzt eine sehr
nützliche Funktion, genannt Interessante
Orte (Points of Interest = POI als Abkürzung).
Wie Sie auf dem folgenden Bild sehen
können, sind diese interessanten Orte für
einen einfachen Zugang in Kategorien
unterteilt.

Als Beispiel wählen wir Attraktion (Attraction).



70

Unter Attraktion (Attraction) finden wir die
nachstehend aufgelisteten
Unterkategorien.  In unserem Beispiel
wählen wir Freizeitpark (Amusement
Park).

Teil I – Menü Datei (File)
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Teil I – Menü Datei (File)

Treffen Sie Ihre Wahl aus der
nachstehenden Liste.  Wählen wir mal
Alphabetisch (Alphabetical), um alle
Freizeitparks in Ihrer Nähe anzuzeigen.
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Treffen Sie Ihre Wahl aus der
nachstehenden Liste und klicken Sie dann
auf OK.

Teil I – Menü Datei (File)
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Um die Karte Ihres interessanten Ortes
anzuzeigen, klicken Sie oben rechts auf OK.
Sie können auch unten im Bildschirm auf
das Symbol Nav oder Karte (Map) klicken.

Teil I – Menü Datei (File)
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Teil I – Menü Datei (File)

Ziel einstellen (Set Destination) –
Kontakte (Contacts)
Sie können auch ein Ziel von einer Person
in Ihrem Kontaktbuch einstellen, deren
Adresse Sie eingegeben haben.  Beachten
Sie jedoch, dass die Adresse des
Kontakts in einem richtigen Format
eingegeben sein muss, damit dies
funktioniert.  Unterstützung hierfür
finden Sie im Handbuch/in der
Benutzerdokumentation Ihres PDAs.

Wenn Ihr Kontaktbuch leer ist, erhalten Sie
beim Anklicken ein leeres Fenster, ähnlich
dem Folgenden.
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Teil I – Menü Datei (File)

Ist Personen im Kontaktbuch eingetragen,
werden ihre Daten angezeigt.  Treffen Sie Ihre
Wahl und klicken Sie dann auf OK.
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Klicken Sie auf den Kontakt, um seine
Adresse anzuzeigen.

Teil I – Menü Datei (File)
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Ziel einstellen (Set Destination) –
Favoriten (Favorites)
Um ein Ziel auszuwählen, das Sie zuvor als
Favoritenziel (Favor ite Destination)
eingegeben haben, klicken Sie auf diese
Option.  Treffen Sie Ihre Auswahl aus der
Liste und klicken Sie unten auf das Symbol
Nav oder Karte (Map).  Hinweis: Durch
Klicken auf das Symbol Bearb (Edit) oder
Entf (Del) können Sie einen Eintrag in
diesem Fenster bearbeiten oder löschen.

Teil I – Menü Datei (File)
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Ziel einstellen (Set Destination) –
Kürzlich (Recent)
Alle von Ihnen zuletzt verwendeten Ziele
sind hier gespeichert.  Möchten Sie eines
davon als Ziel einstellen, wählen Sie es
aus der folgenden Liste aus und klicken
Sie dann unten auf das Symbol Nav oder
Karte (Map), um die Karte anzuzeigen.

Teil I – Menü Datei (File)
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Teil I – Menü Datei (File)

2.  Aktuellen Standort speichern (Save
Current Location) (Datei (File) ➔ Aktuellen
Standort speichern (Save Current Location))
– speichert Ihren aktuellen Standort auf der
Karte.  Dieser Standort wird im Ordner
Favoriten (Favorites) gespeichert.
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Teil I – Menü Datei (File)
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Teil I – Menü Datei (File)

3.  Route abbrechen (Cancel Route)
(Datei (File) ➔ Route abbrechen (Cancel
Route)) – bricht eine von Ihnen
eingegebene Route ab

Tipp: Um zu überprüfen, ob die Route
gelöscht wurde, klicken Sie auf Ansicht
(View) ➔ Routenliste (Route List),
woraufhin Sie ein leeres Fenster, ähnlich
dem Folgenden, sehen sollten:
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Teil I – Menü Datei (File)

4.  Route aufzeichnen (Record Track)
(Datei (File) ➔ Route aufzeichnen (Record
Track)) ]

Klicken Sie zur Routenaufzeichnung auf
Route aufzeichnen (Record Track),
woraufhin nachstehendes Fenster
angezeigt wird.  Geben Sie die
erforderlichen Informationen ein und
klicken Sie dann auf OK, um mit der
Aufzeichnung zu beginnen.
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Teil I – Menü Datei (File)

5.  Route wiedergeben (Play Track) (Datei
(File) ➔ Route wiedergeben (Play Track))

gibt eine zuvor aufgezeichnete Route wieder
Klicken Sie zur Wiedergabe einer zuvor
aufgezeichneten Route auf Route
wiedergeben (Play Track) und wählen Sie
die Datei, die Sie wiedergeben möchten.
Tipp: Um die Routenwiedergabe zu
stoppen, klicken Sie auf Datei (File) à Route
stoppen (Stop Track).
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Teil I – Menü Datei (File)

6.  Demo starten (Start Demo) (Datei
(File) ➔ Demo starten (Start Demo))

Eine der nützlichsten Funktionen der
Navigationssoftware ist die Demo-
Funktion, mit der Sie ein Demo Ihrer
tatsächlichen Route für das angegebene
Ziel betrachten können.  Dies ist sehr
praktisch, wenn Sie Einstellungen auf dem
PDA vornehmen/ändern müssen, was Sie
vor der Fahrt ganz bequem erledigen
können.

Tipp:  Tippen Sie jedoch auf Demo starten
(Start Demo) und nichts passiert, müssen
Sie zuvor ein Ziel angegeben haben.
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Teil I – Menü Datei (File)

7.  Info über Navigationssystem (About
Navigation System) (Datei (File) ➔ Info
über Navigationssystem (About Navigation
system))

Zeigt ein Fenster mit Informationen über die
Kartensoftware
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Teil I – Menü Datei (File)

8.  Hilfe (Help) (Datei (File) ➔ Hilfe (Help))

Zeigt den integrier ten Hilfeinhalt der
Navigationssoftware.
Dies ist eine sehr nützliche Funktion, wenn
Sie schnell wissen müsen, wie bestimmte
Aufgaben in der Navigationssoftware
ausgeführt werden.
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Teil I – Menü Datei (File)

9.  Beenden (Exit) (Datei (File) ➔
(Beenden) Exit) – beendet das Programm
und entfernt es aus dem PDA-Speicher
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1.  Sicherheitsfunktionen (Safety
Features) (Extras (Tools) ➔
Sicherheitsfunktionen (Safety Features))

Hhelfen Ihnen, sicherer zu fahren.

Teil II – Menü Extras (Tools)
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Tempowarnung (Speed Alert)
Möchten Sie einen Soundalarm erhalten,
wenn Sie ein bestimmtes Tempolimit
erreichen, müssen Sie Tempowarnung
(Speed Alert) aktivieren.  Ist sie auf Autom.
(Auto) eingestellt, legt die
Navigationssoftware das Tempolimit
anhand des Straßentyps fest, auf dem Sie
sich befinden (Stadtstraße, Autobahn,
etc.).  Diese Warnung ist lediglich als
Bezugspunkt zu betrachten und erhebt
nicht den Anspruch, genau zu sein.  Bei
Verwendung dieser Funktion sollten Sie
jedoch alle Tempolimits und
Verkehrsregeln beachten und immer
vernünftig handeln.

Teil II – Menü Extras (Tools)
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Teil II – Menü Extras (Tools)

Nebelfahrt (Fog Driving)
Bei Aktivierung dieser Option benachrichtigt
Sie die Software, wenn Sie sich einer
Kreuzung nähern.
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Teil II – Menü Extras (Tools)

2.  Entfernungseinheit (Distance Units)
(Extras (Tools) ➔ Entfernungseinheit (Dis-
tance Units))

Stellt die Einheit der von der
Navigationssoftware angezeigten
Entfernung ein.
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Teil II – Menü Extras (Tools)

3.  Routenoptionen (Route Options)
(Extras (Tools) ➔ Routenoptionen (Route
Options))

Passt die Software dahingehend an, dass
sie Ihnen Richtungsanweisungen auf der
Basis von bevorzugten Einstellungen gibt.
Es folgt eine kurze Erklärung dieser
Einstellungen.  Weitere Informationen
finden Sie im Hilfemenü (Datei (File) à Hilfe
(Help))
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Teil II – Menü Extras (Tools)

Methode (Method)

Schnell (Quickest) – Gibt Ihnen Richtungsanweisungen, die Sie schneller zum Ziel bringen
(z.B. Autobahn bei langen Fahrten und Vermeiden von lokalen, verstopften Straßen)

Kurz (Shortest) – Gibt Ihnen Richtungsanweisungen auf Basis der kürzesten Route
entsprechend der tatsächlichen Entfernung (ist nicht immer die schnellste Route)

Wichtig (Major) – Gibt Ihnen Richtungsanweisungen auf Basis der wichtigsten Straßen
(wenn Sie befürchten, sich auf unbekannten Straßen zu verirren)

Lokal (Local) – Gibt Ihnen Richtungsanweisungen nur für lokale Straßen (vermeidet
Autobahnen)
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Teil II – Menü Extras (Tools)

4.  Anzeigeoptionen (Display Options) (Ex-
tras (Tools) ➔ Anzeigeoptionen (Display
Options))

Es folgt eine kurze Erklärung dieser
Einstellungen.  Weitere Informationen
finden Sie im Hilfemenü (Datei (File) ➔ Hilfe
(Help))
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Teil II – Menü Extras (Tools)

Kartenausrichtung (Map Orientation) – ändern Sie diese Einstellung Ihrer Standrichtung
entsprechend, um sich auf der Karte besser orientieren zu können

Farbschema (Color Scheme)
Autom. (Auto) – ändert Tag/Nachtsicht bei Sonnenaufgang/Sonnenuntergang
Tag (Day) – zeigt einen Bildschirm für normale Tagsicht
Nacht (Night) – der Kartenhintergrund wird dunkler und die Straßen werden heller, damit
man sie besser erkennen kann

Führungsbildschirm (Guidance Screen) – auf Autom. (Auto) eingestellt, wird die Karte
eingezoomt, wenn Sie das betreffende Gebiet erreichen; andernfalls müssen Sie das
Gebiet manuell anklicken.

Interessante Orte-Symbole (POI Icons) – bei Aktivierung zeigt die Karte Symbole,
wenn Sie an interessanten Orten, die in der Kartendatenbank enthalten sind, vorbeifahren

3D-Kartensicht (3D Map View) – Sie können die Kartensicht auf 3D abändern, um ein
realistischeres Bild zu erhalten
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Teil II – Menü Extras (Tools)

5.  Hotkey-Optionen (Hotkey Options)
(Extras (Tools) ➔ Hotkey-Optionen (Hotkey
Options))

Weisen Sie einer PDA-Taste eine
bestimmte Aufgabe zu
Dies ist eine sehr nützliche Funktion der
Software, denn hiermit können Sie PDA-
Tasten so programmieren, dass sie beim
Drücken einer Taste bestimmte
Navigationsfunktionen der Software
ausführen.

Wählen Sie eine Funktion aus der Liste und
klicken Sie dann auf die PDA-Taste, die
diese betreffende Funktion ausführen soll.

Hierbei sehen Sie die Tastennummer unter
der Registerkarte “Taste” (Button).  Möchten
Sie die Zuweisung rückgängig machen,
klicken Sie für die ausgewählte Funktion auf
Taste löschen (Clear Key) oder auf “Alles
löschen” (Clear All), um alle
Tastenbelegungen zu löschen.
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Teil II – Menü Extras (Tools)

Folgende Funktionen können Sie einer
PDA-Taste zuweisen:

3D-Modus (3D Mode)
Aktuelle Position (Current Position)
Interessante Orte-Symbole anpassen
(Customize POI Icons)
Umleitung (Detour)
Anzeigeoptionen (Display Options)
Ziel eingeben (Enter Destination)
Vollbild (Fullscreen)
GPS-Info (GPS Info)
Menü (Menu)
Stumm (Mute)
Norden/Herauffahren (North/Heading Up)

Interessante Orte-Symbole ein/aus (POI
Icons On/Off)
Routenliste (Route List)
Routenoptionen (Route Options)
Tempowarnung (Speed Alert)
Lautstärke (Volume)
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Teil II – Menü Extras (Tools)

6.  Eingabeoptionen (Input Options) (Ex-
tras (Tools) ➔ Eingabeoptionen (Input Op-
tions))

Legt fest, wie Sie Informationen für das
Navigationssystem eingeben

Pocket PC-Tastatur (Pocket PC Keyboard)

Alle Eingaben müssen vom Nutzer über die
Tastatur auf dem PDA-Bildschirm
vorgenommen werden (in diesem Fall durch
Tippen auf das Tastatursymbol, dass Sie
unten rechts auf dem nachstehenden Bild
sehen).
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Navigationssystem-Tastatur (Navigation
System Keyboard)

Alle Eingaben werden über die integrierte
Tastatur der Navigationssoftware
vorgenommen.  Dies ist viel praktischer,
denn die Tasten werden auf dem PDA
größer dargestellt, und Sie können auf
Wunsch weiterhin mit der Pocket PC-
Tastatur arbeiten.
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Teil II – Menü Extras (Tools)

7.  GPS-Optionen (GPS Options) (Extras
(Tools) ➔ GPS-Optionen (GPS Options))

Wählen Sie manuell Einstellungen für Ihr
GPS oder setzen Sie diesen Punkt auf
Autom. erkennen (Auto Detect)
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Hinweis: Die Nummer des COM-Anschlusses
(COM Port) ist die Nummer des ausgehenden
COM-Anschlusses, mit dem sich Ihr Computer/
PDA mit dem GPS verbindet.  Setzen Sie dies nur
auf manuell, wenn Sie sicher sind, welchen COM-
Anschluss Ihr PC/PDA verwendet.

Teil II – Menü Extras (Tools)

Die Baudrate (Baud Rate) sollte auf 4800
gesetzt werden
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8.  Führungslautstärke (Guidance Vol-
ume) (Extras (Tools) ➔ Führungslautstärke
(Guidance Volume))

Stellt den Lautstärkepegel des
Navigationssystems für Sprachbefehle ein.
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Teil III – Menü Ansicht (View)

Menü Ansicht

1.  Karte (Map) (Ansicht (View) ➔ Karte
(Map))

Bringt Sie zurück zur Kartenansicht
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2.  Führung (Guidance) (Ansicht (View) ➔
Führung (Guidance))

Zoomt Ihre aktuelle Position ein und
informiert Sie über das nächste Manöver
(z.B.: nach links/rechts abbiegen).

Tipp: Dies wird per Standard automatisch
vom Navigationssystem getan.  Wenn Sie
dies ändern möchten, wechseln Sie zu: Ex-
tras (Tools) ➔ Anzeigeoptionen (Display
Options) ➔ Führungsbildschirm (Guidance
Screen) ➔ Autom./Manuell (Auto/Manual).

Teil III – Menü Ansicht (View)
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3.  Routenliste (Route List) (Ansicht
(View) ➔ Routenliste (Route List))

Zeigt Textanweisungen, wie Sie zum Ziel
gelangen

Teil III – Menü Ansicht (View)
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4.  GPS-Info (GPS Info) (Ansicht (View) ➔
GPS-Info (GPS Info)) – zeigt GPS-
Statusinformationen und andere nützliche
Informationen

UTC-Zeit (UTC Time) – koordinierte
Weltzeit
Ortszeit (Local Time) – die Zeit Ihres
Gebiets

Unter Standort (Location) können Sie
auch Ihren Breitengrad (Latitude),
Längengrad (Longitude) und Ihre Höhe
(Altitude) ablesen.

NMEA - National Marine Electronics Asso-
ciation.  Die in diesem Fenster angezeigten
Informationen zeigen die Informationen, die
vom GPS empfangen werden.
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Teil III – Menü Ansicht (View)
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5.  Almanach (Almanac) (Ansicht (View)
➔ Almanach (Almanac))

Zeigt Sonnen/Mondinformationen



109

Teil III – Menü Ansicht (View)

6.  Einzoomen/Auszoomen (Zoom +/
Zoom -) (Ansicht (View) à Einzoomen/
Auszoomen (Zoom +/Zoom -))

Anklicken, um ein Gebiet ein/
auszuzoomen.  Sie können auch unten auf
der Karte auf die blauen Symbole +/-
klicken.
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Fehlerbehebung

Eine detaillierte Liste zur Fehlerbehebung/mit häufig gestellten Fragen (FAQ) finden Sie
im Abschnitt Fehlerbehebung und häufig gestellte Fragen (Troubleshooting and Frequently
Asked Questions) in Navigationssystem-Software (Datei (File) à Hilfe (Help)).

1.  Ich erhalte während der Karteninstallation einen Schreibfehler.
Der Grund könnte ein nicht ausreichender Speicher auf dem Computer/PDA sein.
Installieren Sie die Karten auf einem anderen Standort oder installieren Sie mehr Speicher
auf Ihrem Gerät.

2.  Mein IOGEAR Bluetooth-GPS kann die Position nicht ermitteln.
Vergewissern Sie sich, dass sich das Gerät im Freien befindet, entfernt von hohen
Gebäuden/Strukturen oder Objekten, die Störungen verursachen könnten.  Achten Sie
auch darauf, dass das GPS voll aufgeladen ist (es dauert ca. 3 Stunden, um eine volle
Ladung zu erhalten).
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Troubleshooting

Lässt sich die Position weiterhin nicht ermitteln, setzen Sie das GPS zurück, wie in der
Hardware-Schnellstartanleitung beschrieben ist.

3.  Mein PDA reagiert nicht mehr oder nur sehr langsam, nachdem ich das
Navigationssystem geladen habe.
Vergewissern Sie sich zuallererst, dass Ihr PDA den Mindest-Systemanforderungen
entspricht.  Prüfen Sie auch alle laufenden Programme auf dem PDA.  Wenn zu viele
Programme im Hintergrund laufen, belegen Sie den Systemspeicher und verlangsamen
somit das PDA.

4.  Die Navigationssoftware lädt sich nicht auf meinem PC/PDA.
Vergewissern Sie sich, dass Ihr Gerät den Mindest-Software-Systemanforderungen
entspricht.
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5.  Ich habe Schwierigkeiten, eine Bluetooth-Kommunikation zwischen dem PC/
PDA und dem GPS herzustellen.
Schlagen Sie in der Hardware-Schnellstartanleitung nach, wie Sie hier vorzugehen haben.
Wenn Sie dennoch Schwierigkeiten haben, dann suchen Sie im Handbuch Ihres Bluetooth-
Geräts nach Hinweisen.

Fehlerbehebung
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Technische Daten
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Technische Daten
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Technischer Support

Wenn Sie technischen Support benötigen, besuchen Sie bitte unsere IOGEAR Tech Info
Library (T.I.L.) unter www.iogear.com/support, um dort die neuesten Tipps, Tricks und
Hinweise zur Fehlerbehebung zu beziehen. Die IOGEAR Tech Info Library dient dazu,
Sie mit den neuesten technischen Informationen über unsere Produkte zu versorgen. Sie
finden hier fast alle Antworten auf Ihre Fragen; erkundigen Sie sich daher bitte erst hier,
bevor Sie sich an unseren technischen unterstützung wenden.

Die technische unterstützung ist von Montag bis Freitag von 7.30 Uhr bis 17.30 (Pazifiische
Standardzeit) unter der Nummer+1 94 94 53 87 82 oder per E-Mail support@iogear.com
zu erreichen.
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Erklärung zu Radio- & Fernsehstörungen

ACHTUNG!!!  Dieses Gerät erzeugt und verwendet Funkfrequenzenergie, die ausgestrahlt
werden kann und bei unsachgemäßer, nicht der Anleitung des Herstellers entsprechender
Installation und Verwendung schädliche Störungen des Rundfunkempfangs verursachen
kann.  Dieses Gerät wurde geprüft und erfüllt die Grenzwerte für ein Digitalgerät der
Klasse B gemäß Teil 15 der Richtlinien der amerikanischen Bundesbehörde für das
Fernmeldewesen FCC (Federal Communications Commission). Diese Grenzwerte stellen
einen angemessenen Schutz gegen schädliche Funkstörungen innerhalb von
Wohngebäuden sicher.  Der Betrieb dieses Geräts in einer Wohngegend kann
möglicherweise Störungen verursachen. In diesem Fall muss der Benutzer Maßnahmen
zur Behebung der Störung auf eigene Kosten ergreifen.
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Eingeschränkte Garantie

UNTER KEINEN UMSTÄNDEN ÜBERSCHREITET DER FÜR DAS PRODUKT
GEZAHLTE PREIS DIE HAFTUNG DES DIREKTANBIETERS FÜR DIREKTE,
INDIREKTE, BESONDERE, ZUFÄLLIGE SCHÄDEN ODER FOLGESCHÄDEN, DIE BEI
VERWENDUNG DES PRODUKTS, DER CD-ROM ODER SEINER DOKUMENTATION
ENTSTEHEN.

Der Direktanbieter gibt keine ausdrücklichen, indirekten oder gesetzlichen Garantien oder
Verpflichtungen zum Inhalt oder zur Verwendung dieser Dokumentation und lehnt
insbesondere die Haftung für die Qualität, Leistung, Marktfähigkeit oder Eignung für einen
bestimmten Zweck ab.

Der Direktanbieter behält sich auch das Recht vor, das Gerät oder die Dokumentation zu
überarbeiten oder zu aktualisieren, ohne Einzelpersonen oder juristischen Personen von
derartigen Überarbeitungen oder Updates in Kenntnis zu setzen.  Weitere Fragen
beantwortet Ihnen gerne Ihr Direktanbieter.
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