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Bienvenue

Merci d’avoir choisi le système GPS Bluetooth IOGEAR.  Cette unité GPS Bluetooth est
un système de navigation en temps réel. Le récepteur GPS Bluetooth vous permet de
recevoir les données de positionnement des satellites et de fournir les données aux
périphériques informatiques mobiles, sans fil, via Bluetooth. Il apporte des capacités de
positionnement totalement fiables et de suivi de haute précision. Le design ultra-basse
consommation d’énergie et la batterie rechargeable longue durée vous permettent d’avoir
25 heures d’utilisation continue, et vous évitent d’avoir à recharger l’appareil entre deux
utilisations. Il est portable et léger, de sorte que vous pouvez le placer sur votre tableau
de bord ou sur n’importe quel emplacement qui permet de voir directement le ciel.

Plus jamais vous ne serez perdu!
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Configuration système requise

Ordinateur de bureau/portable :

Windows ME/2000/XP
Au minimum 256 Mo de RAM système et au moins 512 Mo d’espace disponible sur le
disque dur
Doit avoir la capacité Bluetooth et prendre en charge le profil port série

PDA (Pocket PC) :

Nécessite Microsoft Pocket PC 2002 ou version ultérieure
Le PDA doit posséder un processeur à au moins 266 MHz avec au moins 64 Mo de
mémoire principale disponible
Il est recommandé d’avoir une carte de stockage d’au moins 64 Mo pour charger les
cartes supplémentaires
Doit avoir la capacité Bluetooth et prendre en charge le profil port série
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Caractéristiques du logiciel

• Les alertes vocales intersection par intersection vous aident à rester concentré sur
la route

• L’aide à la déviation d’itinéaire vous aide à arriver à bon port même si vous vous
trompez d’intersection

• Options pour itinéraires le plus rapide, le plus court, routes locales, routes
principales, covoiturage

• Écran d’instructions automatiques pour les manœuvres

• Affichage des cartes en temps réel

• Plein écran automatique

• Affichage détaillé des cartes avec noms des rues

• Schéma couleur jour / nuit automatique

• Vue plongeante 3-D
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Caractéristiques du logiciel

• Options de touches d’accès rapide pour raccourcis des commandes via les
boutons de votre PDA

• Fonctions spéciales de sécurité avec alarmes de dépassement de vitesse et de
brouillard

• Base de données des points d’intérêt majeur (POI)

• Destinations préférées et récentes

• Boîte d’état facilement accessible affichant ETA (Estimation de l’heure d’arrivée),
distance et vitesse

• Enregistrement et relecture d’itinéraire

• Le mode démo vous donne une simulation de conduite de votre trajet

• Base de données de cartes Navteq
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Installation du logiciel

Check-list

Avant d’aller plus avant, veuillez vérifier ce qui suit :

• Le présent guide suppose que vous avez déjà installé Microsoft ActiveSync
et que vous l’avez déjà configuré de façon à pouvoir transférer les données
entre votre PDA et votre ordinateur.

• Connectez votre PDA à l’ordinateur par le biais de son berceau ou de son
câble de synchronisation
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Installer le logiciel

1. Insérez le CD d’installation et de
configuration fourni dans le paquet.
Le CD sera lancé et commencera
automatiquement la procédure
d’installation.

2. L’assistant d’installation affichera la
fenêtre reproduite ci-dessous.
Cliquez sur Suivant (Next) pour
continuer.

Installation du logiciel
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3. Si vous acceptez les termes de
l’accord de licence, cliquez sur
Oui (Yes).

Installation du logiciel
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Installation du logiciel

4. Dans la fenêtre suivante, vous
pouvez sélectionner la version
du logiciel de navigation que
vous voulez installer.  Veuillez
faire votre sélection, puis
cliquez sur Suivant (Next).
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Installation du logiciel

5. Attendez quelques instants,
le temps que les fichiers
d’installation soient transférés
sur votre ordinateur.
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Installation du logiciel

6. Si vous avez coché la case “Pocket
PC”, vous verrez s’afficher une invite
similaire à l’image ci-dessous.  Si vous
souhaitez installer le programme dans
la mémoire principale de votre PDA,
cliquez sur Oui (Yes).

Cependant, si vous souhaitez installer le
logiciel de navigation sur un autre emplace-
ment, cliquez sur Non (No).  Vous verrez
alors s’afficher une fenêtre dans laquelle
vous pouvez spécifier l’endroit où installer
les fichiers programme.  Faites votre
sélection, puis cliquez sur OK.
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Installation du logiciel

7. Le logiciel préparera les fichiers à
installer sur votre PDA.

8. Vérifiez si vous avez besoin
d’accomplir d’autres opérations sur
votre PDA pour mener à bien
l’installation du programme.



16

9. Cliquez sur Terminer (Finish) pour
terminer l’installation, puis passez
à la section suivante.

Installation du logiciel
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Chargement des cartes

10.  Une fois que vous avez chargé le logiciel
de cartes, vous pouvez sélectionner les
cartes que vous souhaitez installer sur votre
périphérique.  Il y a deux méthodes pour
installer vos cartes – par région ou par ville.
Si vous disposez de moins de 64 Mo
d’espace de stockage, il est recommandé
d’installer les cartes “Par ville” (“By City”).
Cependant, si vous disposez d’un espace
de stockage suffisant, vous pouvez installer
vos cartes en utilisant l’option Par région
(By Region).

Si vous regardez sur le côté droit, vous
verrez que vous pouvez sélectionner
l’Emplacement cible (Target Location) sur

lequel charger les cartes (sur votre PDA
ou votre ordinateur).  Vous pourrez
également voir l’espace de stockage
disponible sur l’emplacement que vous
avez sélectionné, et la taille, exprimée en
méga-octets, des cartes que vous avez
sélectionnées.

Remarque: Lorsque vous sélectionner les zones
de cartes à installer, le logiciel de navigation
construit une carte qui regroupe ensemble toutes
ces zones.  Si vous souhaitez ajouter d’autres
zones ultérieurement, le logiciel de navigation
devra reconstruire l’ensemble de la carte ; dès
lors, vous devez sélectionner toutes les cartes que
vous aviez sélectionnées précédemment, plus la
nouvelle carte que vous ajoutez.
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Méthode 1 - Par région:
Avec cette option, vous pouvez installer les
cartes d’un État entier.  Si l’État que vous
choisissez est marqué d’un signe “+”, cela
signifie que vous pouvez choisir de
n’installer que certaines portions de cet
État (ainsi qu’illustré dans l’image ci-
dessous).  Pour charger la carte de l’État
entier, veillez à bien cocher toutes les
cases qui se trouvent éventuellement sous
le signe “+”.

Une fois que vous avez sélectionné toutes
les cartes voulues, cliquez sur “Générer la
carte” (“Generate Map”) pour commencer
à installer les cartes.

Chargement des cartes
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11.  Sinon, si l’espace de stockage dont
dispose votre ordinateur ou votre PDA est
limité, vous pouvez charger les cartes en
utilisant l’option Par ville (By City).

Méthode 2 - Par ville:
Sélectionnez tout d’abord une Région (un
État) pour la carte qui vous intéresse.
Sélectionnez ensuite la ville, puis le rayon
sur la carte dans lequel vous prévoyez
d’utiliser le système GPS.

Sous Emplacement cible (Target Loca-
tion), spécifiez l’endroit sur lequel vous
voulez charger les cartes.  Une fois que
vous êtes prêt à installer la carte, cliquez
sur “Générer la carte” (“Generate Map”).

Chargement des cartes
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Chargement des cartes

12.  Le logiciel d’installation commence alors
à installer vos cartes.
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Chargement des cartes

13.  En fonction de vos sélections, il se peut
que vous soyez invité à insérer le CD dans
lequel se trouvent les données de votre carte.
Faites-le, puis cliquez sur OK pour continuer.

Remarque:  Soyez patient, car l’installation des
cartes peut nécessiter jusqu’à 30 minutes, selon la
taille de la carte chargée.
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14.  Une fois l’installation terminée, vous
verrez s’afficher une fenêtre de ce type:

Chargement des cartes
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Configuration du logiciel pour l’utilisation avec l’unité GPS

Check-list
Avant d’aller plus avant, veuillez vérifier ce qui suit :

• L’unité Bluetooth est SOUS tension et elle est en vue directe avec le ciel

• Votre ordinateur/PDA a établi un

• Vérifiez que vous avez bien installé le logiciel de navigation sur votre périphérique

• Vérifiez que vous avez bien installé toutes les cartes voulues
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1.  Établissez une connexion de port série
Bluetooth entre votre ordinateur/PDA et votre
unité GPS Bluetooth, ainsi que décrit dans
le “Guide de démarrage rapide du matériel”.
Si vous n’accomplissez pas cette procédure,
le logiciel n’est pas en mesure de trouver
l’unité GPS.

2.  Allez dans le dossier programmes de votre
PDA et cliquez sur l’icône de carte qui s’y
trouve pour charger le logiciel de navigation.

Configuration du logiciel pour l’utilisation avec l’unité GPS
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3.  Au démarrage, vous verrez s’afficher un
message de mise en garde concernant la
procédure à suivre pour garantir votre
sécurité pendant que vous utilisez votre
équipement GPS.  Cliquez simplement sur
OK pour continuer.

Configuration du logiciel pour l’utilisation avec l’unité GPS
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Configuration du logiciel pour l’utilisation avec l’unité GPS

4. Si vous avez déjà déterminé la position
GPS, la carte affiche votre position courante.
Sinon, elle affiche la dernière position
connue.
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Les icônes que vous voyez à l’écran vous permettent de modifier rapidement les
paramètres les plus utilisés pour votre logiciel de navigation.

Vous permet d’activer ou de désactiver le volume des commandes
vocales

Vous permet d’entrer une destination, de changer la vue de la carte, de
changer les options d’itinéraire/d’affichage, d’enregistrer les informa-
tions concernant l’itinéraire, de régler le volume et de visualiser les
infos GPS.

Afficher les infos GPS

Changer votre destination

Configuration du logiciel pour l’utilisation avec l’unité GPS
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Sur le bas de l’écran, il y a trois options de
menu : Fichier (File), Outils (Tools) et Menu.
Pour des explications et une discussion
détaillées sur ces menus, veuillez aller à
la page48.

Configuration du logiciel pour l’utilisation avec l’unité GPS



29

5.  La première chose à faire est de configurer
le logiciel de navigation pour qu’il détecte
l’unité GPS Bluetooth.  Pour ce faire, cliquez
sur Outils (Tools) et allez sur Options GPS
(GPS Options).

Configuration du logiciel pour l’utilisation avec l’unité GPS
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6.  Maintenant, sélectionnez Détection auto
(Auto Detect).

42

Configuration du logiciel pour l’utilisation avec l’unité GPS
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Configuration du logiciel pour l’utilisation avec l’unité GPS

7.  Le logiciel de navigation commence à
détecter votre unité GPS.  Cliquez simplement
sur OK pour commencer à balayer.
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Configuration du logiciel pour l’utilisation avec l’unité GPS

8.  A ce moment-là, si votre PDA n’a pas établi
la connexion avec votre GPS Bluetooth, il se
peut que vous voyiez s’afficher une fenêtre
donnant tous les périphériques Bluetooth qui
sont à votre portée.  Si c’est le cas, veuillez
sélectionner le GPS Bluetooth et cliquer sur
OK.  Cependant, si, après plusieurs
tentatives, le logiciel de navigation ne
parvient pas à trouver votre GPS, assurez-
vous que vous avez bien suivi la procédure
donnée dans le Guide de démarrage rapide
du matériel pour établir une connexion de
port série entre votre périphérique et
l’unité GPS.
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Configuration du logiciel pour l’utilisation avec l’unité GPS

Il se peut aussi qu’il vous soit demandé de
taper une Clé de passe ou un Code PIN.  Si
c’est le cas, veuillez taper “0000” (quatre
zéros), puis cliquez sur OK.
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Configuration du logiciel pour l’utilisation avec l’unité GPS

9.  Une fois que le logiciel a détecté votre
GPS, il vous suffit de cliquer sur OK pour
confirmer les paramètres.
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Configuration du logiciel pour l’utilisation avec l’unité GPS
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10.  Une fois que vous avez établi la
connexion avec l’unité GPS, vous serez placé
en vue carte.  Veuillez passer à la section
suivante “Vérifier la connexion du satellite
GPS”.

Configuration du logiciel pour l’utilisation avec l’unité GPS
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Vérification de la connexion satellite GPS

1.  L’étape suivante consiste à vérifier que le
GPS a bien déterminé sa position.  Pour ce
faire, cliquez sur Affichage (View) > Infos GPS
(GPS Info).
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Vérification de la connexion satellite GPS

2.  Si l’unité GPS a déterminé sa position,
vous verrez s’afficher quelque chose de
similaire à la fenêtre ci-dessous.  Les barres
vertes indiquent les satellites auxquels l’unité
GPS est connectée.  Les barres rouges
indiquent qu’une liaison n’a pas été établie
avec le satellite correspondant.  Pour pouvoir
utiliser le GPS, vous devez être connecté à
au moins trois (3) satellites.

Position GPS déterminée:

Dans le cas présent, vous pouvez voir
que le GPS est connecté à cinq
satellites sur huit :



39

Vérification de la connexion satellite GPS

Position GPS non déterminée :
Dans le cas présent, vous pouvez voir

que le GPS n’a pas déterminé sa position
GPS et qu’il n’est connecté à aucun satellite
(ce qui est indiqué par les barres rouges).
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Si votre unité GPS à des problèmes
pour se connecter aux satellites, veuillez
prendre les mesures suivantes :

• Éloignez le GPS des bâtiments et
structures élevés

• Éloignez le GPS de tout objet qui
risque de gêner les signaux radio

• Placez le GPS dans un endroit où il
est en vue directe avec le ciel (de
préférence à l’extérieur)

Vérification de la connexion satellite GPS
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Introduction – Mise en route

Vue carte

direction du
changement de
direction

prochaine rue
dans laquelle
tourner

nombre de miles
jusqu’à votre
destination (si vous
cliquez ici, affiche
la vitesse, le temps
restant – REM et
l’heure estimée
d’arrivée – ETA).

votre position
actuelle

distance de la
prochaine rue
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Introduction – Mise en route

Icônes de raccourci
Comme vous pouvez le voir dans l’image ci-dessus, il y a un certain nombre d’icônes de
raccourci à l’écran qui vous permettent d’accéder facilement aux tâches communes
associées à votre logiciel de navigation.  Pour accéder à toutes les fonctions du logiciel,
cliquez sur le menu Fichier (File), Outils (Tools) et Affichage (View) sur le bas de l’écran
(les explications correspondantes sont données plus loin dans le manuel).
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Dans la section ci-dessous, nous allons brièvement expliquer ce qu’est chacune de
ces fonctions et ainsi que son utilisation.

Vous permet d’ACTIVER/de DÉSACTIVER l’audio du système de navigation

Afficher les informations d’état GPS

Changer l’orientation de la carte

Introduction – Mise en route
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Icônes d’état GPS
Ces icônes sont affichées sur la zone de la carte et ont les significations suivantes :

État GPS :  Lié aux satellites

État GPS :  Tentative de rétablissement de la connexion en cours

État GPS :  Non connecté à un nombre suffisant de satellites

Introduction – Mise en route
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Affiche la zone environnante de la destination sélectionnée sur la carte

Affiche votre position courante sur la carte

Pour ajouter une adresse à vos Favoris, cliquez sur ce bouton

Options de carte
Ces icônes vous permettent de faire ce qui suit :

Introduction – Mise en route
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Faire défiler la carte

Si vous souhaitez voir les zones
environnantes de votre position courante sur
la carte, vous pouvez utiliser la fonction
panoramique.  Pour ce faire, cliquez sur
l’écran du PDA et maintenez le stylet sur votre
carte, puis déplacez-le dans la direction que
vous voulez voir, puis relevez le stylet.  La
carte se déplacera sur cette position.  Pour
quitter ce mode et retourner sur votre position
courante, cliquez sur le X rouge situé dans
le coin inférieur droit.

Introduction – Mise en route
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Lorsque vous cliquez sur l’icône de
menu, vous vous retrouvez dans le
menu principal reproduit ci-dessous

Introduction – Mise en route
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MENU FICHIER (FILE)
1.  Entrer la destination (Menu Fichier (File) ➔
Entrer la destination (Enter Destination))
Cette option de menu vous permet de
sélectionner une position, et vous donne des
instructions bloc après bloc.  Comme vous
pouvez le voir dans le menu ci-dessous, vous
disposez de plusieurs méthodes pour définir une
destination.

Nous vous donnerons ci-dessous quelques
exemples.  Si vous avez encore besoin d’aide,
veuillez utiliser le menu aide dans le logiciel de
navigation en allant sur Fichier (File) ➔ Aide
(Help).

Partie I – Menu Fichier (File)
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Partie I – Menu Fichier (File)

Définir la destination  – Adresse (Set Desti-
nation – Address)
Lorsque vous sélectionnez l’option Adresse
(Address), les deux options ci-dessous vous
seront proposées :

Rue d’abord (Street First) – Lorsque vous
utilisez cette option, les résultats de la recher-
che seront plus nombreux, mais c’est très utile
si vous avez des problèmes à trouver une
adresse en particulier

Ville d’abord (City First) – Cette option est très
utile car elle permet de réduire l’étendue de la
recherche à la ville que vous spécifiez
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Partie I – Menu Fichier (File)
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Partie I – Menu Fichier (File)

Rue d’abord
Entrez le nom de la rue puis cliquez sur le
bouton vert OK.
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Entrez maintenant le numéro de votre desti-
nation, en prenant en compte la plage valable
affichée.  Ensuite, cliquez sur le bouton vert
OK pour lancer la recherche.  Remarque: Si
votre adresse est en-dehors de la plage
affichée, cela signifie probablement que
vous n’avez pas la carte requise pour cette
zone.  Cela risque d’être le cas si vous avez
chargé vous cartes avec l’option “par ville”
(“by city”).  Si c’est le cas, veuillez charger
un rayon de zone plus important pour votre
carte, ou bien sélectionnez l’option “par
région” (“by region”) lorsque vous chargez
votre carte.

Partie I – Menu Fichier (File)
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Partie I – Menu Fichier (File)

Le logiciel de navigation affiche alors une liste
des adresses correspondantes.  Comme
nous l’avons déjà indiqué, lorsque vous
utilisez l’option “rue d’abord” (“street first”),
vous devriez normalement trouver plusieurs
adresses correspondantes.  Sélectionnez
votre adresse, puis cliquez sur OK dans le
coin supérieur droit.
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Partie I – Menu Fichier (File)

Ville d’abord (City First)
Entrez le nom de la ville puis cliquez sur le
bouton vert OK.
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Partie I – Menu Fichier (File)

Maintenant, entrez le nom de la rue, puis
cliquez sur OK
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Entrez le numéro, en tenant compte de la
plage spécifiée.

Partie I – Menu Fichier (File)
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Le logiciel de navigation affiche alors les
adresses correspondantes qu’il a trouvées.
Comme vous pouvez le voir ci-dessous,
l’option “ville d’abord” (“city first”) a permis
de limiter les résultats de la recherche.
Sélectionnez l’adresse désirée, puis cliquez
sur OK dans le coin supérieur droit.

Partie I – Menu Fichier (File)
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Partie I – Menu Fichier (File)

Définir la destination - Intersection
(Set Destination - Intersection)
Avec cette option, vous pouvez entrer les
noms de deux rues qui se croisent comme
destination

Rue d’abord (Street First)
Nous ne vous conseillons pas de
sélectionner cette option pour une
intersection car, le plus souvent, vous
obtiendrez un trop grand nombre de
résultats.  Cependant, si vous n’avez chargé
qu’une portion de carte limitée sur votre
appareil, vous ne vous trouverez pas
confronté à ce type de problème.
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Partie I – Menu Fichier (File)

Entrez le nom de la première rue, puis
cliquez sur OK
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Comme vous pouvez le voir, il y a trop de
résultats.  Cliquez sur OK pour essayer
avec l’option “ville d’abord” (“city first”).

Partie I – Menu Fichier (File)
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Ville d’abord (City First)
Entrez le nom de la ville, puis cliquez sur OK

Partie I – Menu Fichier (File)
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Entrez le nom de la première rue, puis
cliquez sur OK

Partie I – Menu Fichier (File)
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Entrez le nom de la seconde rue, puis
cliquez sur OK

Partie I – Menu Fichier (File)
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Dans ce cas, le logiciel de navigation a
trouvé un résultat pour cette intersection, et
l’utilisation de l’option “ville d’abord”(“city
first”) nous a permis de limiter la recherche
de façon à ne trouver qu’un seul résultat.
Pour afficher la carte, cliquez simplement
sur OK dans le coin supérieur droit.

Partie I – Menu Fichier (File)
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Partie I – Menu Fichier (File)

Définir la destination - Centre ville (Set
Destination – City Center)

Cette option vous permet de rechercher les
centres-villes dans votre zone.

À titre d’exemple, nous choisissons l’option
Alphabétique (Alphabetical).
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Entrez le nom de votre ville, puis cliquez
sur OK

Partie I – Menu Fichier (File)
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Partie I – Menu Fichier (File)

Maintenant, cliquez sur le bouton OK dans
le coin supérieur droit.  Si vous cliquez sur
Nav sur le bas, le logiciel de navigation
vous donne une carte de la destination.
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Voici une carte pour le centre ville
d’Irvine, CA.

Partie I – Menu Fichier (File)
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Partie I – Menu Fichier (File)

Définir la destination - Points d’intérêt
(Set Destination – Points of Interest)

Le logiciel de navigation possède une
fonction très utile appelée Points d’intérêt
(Points of Interest, abrégé en POI).  Comme
vous pouvez le voir dans l’image ci-dessous,
ces POI sont classés en catégories pour
permettre un accès plus facile.

À titre d’exemple, nous sélectionnons
Attraction.
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Sous attraction, vous trouverez la liste des
sous-catégories donnée ci-dessous.  Dans
notre exemple, nous allons choisir Parc
d’attraction (Amusement Park).

Partie I – Menu Fichier (File)
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Faites votre choix dans la liste ci-dessous.
Sélectionnez Alphabétique (Alphabetical)
pour voir tous les parcs d’attraction qui se
trouvent à proximité de notre zone.

Partie I – Menu Fichier (File)
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Dans la liste ci-dessous, faites votre
sélection, puis cliquez sur OK.

Partie I – Menu Fichier (File)
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Pour afficher la carte de votre POI, cliquez
sur OK dans le coin supérieur droit.  Sinon,
vous pouvez aussi cliquer sur l’icône Nav
ou Carte (Map) sur le bas de l’écran.

Partie I – Menu Fichier (File)
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Partie I – Menu Fichier (File)

Définir la destination - Contacts (Set
Destination – Contacts)
Vous pouvez aussi définir une destination
pour quelqu’un qui se trouve dans votre
répertoire et pour qui vous avez entré une
adresse.  Veuillez noter que l’adresse du
contact doit être formatée correctement pour
que cette fonction puisse marcher.  Pour de
l’aide sur ce point, veuillez consulter le
manuel ou la documentation utilisateur de
votre PDA.

Par ailleurs, si votre répertoire est vide, vous
verrez s’afficher une fenêtre vide telle que
celle reproduite ci-dessous lorsque vous
cliquez sur cette option.
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Si vous avez quelqu’un dans votre
répertoire, les informations correspondantes
sont affichées.  Veuillez faire votre sélection,
puis cliquez sur OK.

Partie I – Menu Fichier (File)
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Cliquez sur votre contact pour afficher
son adresse.

Partie I – Menu Fichier (File)
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Partie I – Menu Fichier (File)

Définir la destination - Favoris (Set
Destination – Favorites)

Pour sélectionner une destination que vous
avez précédemment ajoutée comme
Destination favorite (Favorite Destination),
cliquez sur cette sélection.  Faites votre
sélection dans la liste et cliquez sur l’icône
Nav ou Carte (Map) sur le bas.  Remarque:
Vous pouvez éditer ou supprimer toute
entrée se trouvant dans cette fenêtre en
cliquant respectivement sur l’icône Editer
(Edit) ou Suppr (Del).
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Définir la destination - Récent (Set
Destination - Recent)

Toutes les destinations que vous avez
utilisées récemment sont stockées ici.  Si
vous désirez choisir l’une d’entre elles
comme destination, il vous suffit de la
sélectionner dans la liste en-dessous, puis
de cliquer sur l’icône Nav ou Carte (Map) sur
le bas pour afficher la carte correspondante.

Partie I – Menu Fichier (File)
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Partie I – Menu Fichier (File)

2.  Enregistrer la position courante (Fichier
(File) ➔ Enregistrer la position courante
(Save Current Location))

Vous permet d’enregistrer votre position
actuelle sur la carte.  Cette position sera
enregistrée dans votre dossier Favoris (Fa-
vorites).
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Partie I – Menu Fichier (File)



81

Partie I – Menu Fichier (File)

3.  Annuler l’itinéraire (Fichier (File) ➔
Annuler l’itinéraire (Cancel Route))

Utilisez cette fonction pour annuler l’itinéraire
que vous avez entré
Astuce : Pour vérifier que l’itinéraire a bien
été effacé, vous pouvez cliquer sur Affichage
(View) ➔ Liste des itinéraires (Route List), et
vous devriez alors voir s’afficher une fenêtre
vide telle que celle-ci :
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Partie I – Menu Fichier (File)

4.  Enregistrer l’itinéraire (Fichier (File) ➔
Enregistrer l’itinéraire (Record Track))

Pour enregistrer votre itinéraire, cliquez sur
enregistrer l’itinéraire, et vous devriez voir
s’afficher la fenêtre ci-dessous.  Entrez les
informations requises puis cliquez sur OK
pour commencer à enregistrer.
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Partie I – Menu Fichier (File)

5.  Lire l’itinéraire (Fichier (File) ➔ Lire
l’itinéraire (Play Track))

Permet de lire un itinéraire enregistré
précédemment
Pour lire un itinéraire enregistré
précédemment, cliquez sur lire l’itinéraire et
sélectionnez le fichier que vous voulez lire.
Astuce : Pour arrêter de lire l’itinéraire,
cliquez sur Fichier (File) ➔ Arrêter l’itinéraire
(Stop Track).
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Partie I – Menu Fichier (File)

6.  Lancer une démo (Fichier (File) ➔ Lancer
une démo (Start Demo))

L’une des fonctions les plus utiles du logiciel
de navigation est la fonction Démo, qui vous
permet de visualiser une démo de votre
itinéraire réel pour une destination donnée.
C’est très utile lorsque vous avez besoin
d’ajuster/de modifier les paramètres sur votre
PDA, car vous pouvez le faire
confortablement avant de prendre la route.
Astuce:  Si vous cliquez sur Lancer une
démo (Start Demo) et si rien ne se produit,
n’oubliez pas que vous devez d’abord
spécifier une destination.
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Partie I – Menu Fichier (File)

7.  A propos du système de navigation
(Fichier (File) ➔ A propos du système de
navigation (About Navigation system))

Affiche la fenêtre informations du logiciel de
cartes
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Partie I – Menu Fichier (File)

8.  Aide (Fichier (File) ➔  Aide (Help))

Affiche le contenu de l’aide intégrée du
logiciel de navigation.

L’aide est une fonction très utile lorsque vous
avez besoin d’une explication rapide
concernant l’exécution de certaines tâches
dans le logiciel de navigation.
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Partie I – Menu Fichier (File)

9.  Quitter (Fichier (File) ➔ Quitter (Exit))

Permet de quitter le programme et de le
décharger de la mémoire de votre PDA
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1.  Fonctions de sécurité (Outils (Tools) ➔
Fonctions de sécurité (Safety Features))

Vous aide à conduire de façon plus sure.

MENU OUTILS (TOOLS)

Partie II – Menu Outils (Tools)
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Alarme vitesse (Speed Alert)
Si vous souhaitez entendre une alarme
sonore lorsque vous atteignez une certaine
vitesse limitée, activez l’alarme vitesse.  Si
vous choisissez l’option Auto, le logiciel de
navigation détermine la vitesse limitée en
fonction du type de voie sur lequel vous vous
trouvez (ville, autoroute, etc.).  Cependant,
cette alarme n’est fournie qu’à titre
d’indication, et aucune garantie n’est donnée
quant à son exactitude.  Nous vous
conseillons de respecter toutes les limitations
de vitesse et règles du code de la route, et
de faire preuve de bon sens lorsque vous
utilisez cette fonction.

Partie II – Menu Outils (Tools)
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Partie II – Menu Outils (Tools)

Brouillard (Fog Driving)
Si vous activez cette option, le logiciel vous
informera lorsque vous arrivez à proximité
d’une intersection.
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Partie II – Menu Outils (Tools)

2.  Unité de distance (Outils (Tools) ➔Unité
de distance (Distance Units))

Vous permet de changer l’unité utilisée pour
afficher les distances sur votre logiciel de
navigation.
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Partie II – Menu Outils (Tools)

3.  Options d’itinéraire (Outils (Tools) ➔
Options d’itinéraire (Route Options)

Personnalisez le logiciel pour qu’il vous
donne des instructions en fonction de vos
préférences.  Nous donnons ci-dessous une
brève explication concernant ces paramètres.
Pour de plus amples informations, veuillez
utiliser le menu d’aide (Fichier (File) ➔ Aide
(Help))
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Partie II – Menu Outils (Tools)

Méthode

Plus rapide (Quickest) – Vous donne les indications qui vous permettront d’arriver plus
vite à destination (par exemple en empruntant l’autoroute pour les longs trajets et en
évitant les voies locales encombrées)

Le plus court (Shortest) - Vous donne les indications de l’itinéraire le plus court sur la
base de la distance physique (n’est pas forcément le plus rapide)

Principal (Major) – Vous donne des instructions sur la base des voies principales (si vous
ne voulez pas vous perdre dans les petites rues)

Local – Vous donne des instructions pour les voies locales uniquement (pour éviter les
autoroutes)
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Partie II – Menu Outils (Tools)

4.  Options d’affichage (Outils (Tools) ➔
Options d’affichage (Display Options))

Nous donnons ci-dessous une brève
explication concernant ces paramètres.  Pour
de plus amples informations, veuillez utiliser
le menu d’aide (Fichier (File) ➔ Aide (Help))
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Partie II – Menu Outils (Tools)

Jeu de couleurs (Color scheme)
Auto – permet de changer la vue d’écran jour/nuit respectivement au coucher et au lever
du soleil
Jour (Day) – l’écran est en vue normal pour l’affichage de jour
Nuit (Night) – l’arrière-plan de la carte est assombri et les lignes des rues sont éclaircies
pour un meilleur affichage

Écran guide (Guidance Screen) – si le réglage choisi est Auto, permet de faire un zoom
avant sur la carte lorsque vous approchez de la zone à atteindre, sinon vous devez
cliquer manuellement sur la zone.
Icônes POI (POI Icons) – si cette option est activée, la carte affiche les icônes lorsque
vous arrivez à proximité des POI inclus dans la base de données de cartes

Affichage carte 3D (3D Map View) – vous pouvez changer d’affichage pour afficher la
carte en vue 3D pour une vue plus réaliste



96

Partie II – Menu Outils (Tools)

5.  Options touches de raccourci (Outils
(Tools) ➔ Options touches de raccourci
(Hotkey Options))

Attribuez une tâche spécifique à un bouton
de votre PDA
Cette fonction du logiciel est très utile, car
elle vous permet de définir n’importe lequel
des boutons de votre PDA pour exécuter
certaines fonctions du logiciel de navigation
simplement en appuyant sur un bouton.

Il vous suffit de sélectionner une fonction
dans la liste, puis de cliquer sur le bouton
de votre PDA que vous voulez voir exécuter
cette fonction.  Lorsque vous faites cela,
vous devriez voir le numéro du bouton
affiché dans l’onglet appelé “bouton”
(“button”).  Si vous voulez annuler cette
fonction, vous pouvez cliquer sur Annuler
la touche (Clear Key) pour la fonction
sélectionnée, ou bien sur “Annuler tout”
(“Clear All”) pour annuler toutes les
fonctions attribuées aux boutons.
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Partie II – Menu Outils (Tools)

Les fonctions que vous pouvez attribuer à
un bouton du PDA sont :
Mode 3D (3D Mode)
Position actuelle (Current Position)
Personnaliser les icônes POI (Customize
POI Icons)
Détour (Detour)
Options d’affichage (Display Options)
Entrer la destination (Enter Destination)
Plein écran (Fullscreen)
Infos GPS (GPS Info)
Menu (Menu)
Silence (Mute)
Nord/Vers destination (North/Heading Up)
Marche/Arrêt icônes POI (POI Icons On/
Off)

Liste des itinéraires (Route List)
Options d’itinéraire (Route Options)
Alarme vitesse (Speed Alert)
Volume (Volume)
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Partie II – Menu Outils (Tools)

6.  Options d’entrée (Outils (Tools) ➔
Options d’entrée (Input Options)) – vous
permet de définir la méthode utilisée pour
entrer les informations pour le système de
navigation

Clavier Pocket PC (Pocket PC Keyboard)
– toutes les entrées de l’utilisateur doivent
se faire par le biais du clavier à l’écran de
votre PDA (dans ce cas, en cliquant sur
l’icône de clavier que vous voyez dans le
coin inférieur droit de l’image ci-dessous).

Clavier du système de navigation
(Navigation System Keyboard) – utilise le
clavier intégré du logiciel de navigation pour
toutes les entrées.  C’est beaucoup plus
pratique car les touches sont affichées à
un format plus grand que sur le PDA, et
vous pouvez toujours utiliser le clavier de
votre Pocket PC si vous le désirez.
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Partie II – Menu Outils (Tools)



100

7.  Options GPS (Outils (Tools) ➔ Options
GPS (GPS Options))

Sélectionnez manuellement les paramètres
pour votre unité GPS, ou bien sélectionnez
Détection auto (Auto Detect)

Partie II – Menu Outils (Tools)
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Partie II – Menu Outils (Tools)

Remarque: Le numéro de port COM et le
numéro du port COM d’entrée que votre
ordinateur/PDA utilise pour se connecter à
l’unité GPS.  Ne le configurez manuellement
que si vous êtes sûr de port COM qu’utilise
votre PC/PDA.
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Partie II – Menu Outils (Tools)

8.  Volume instructions (Guidance
Volume) (Outils (Tools) ➔ Volume
instructions (Guidance Volume))

Vous permet d’ajuster le niveau du volume
sonore des commandes vocales données
par le système de navigation
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Partie III – Menu Affichage (View)

MENU AFFICHAGE

1.  Carte (Affichage (View) ➔Carte (Map))

Vous ramène sur l’affichage de la carte
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2.  Instructions (Affichage (View) à
Instructions (Guidance))

Fait un zoom avant sur votre position
actuelle et vous informe sur la prochaine
manœuvre à faire (ex.: tourner à gauche/
à droite).
Astuce: Par défaut, le système de
navigation le fait automatiquement.  Si
vous désirez changer cela, allez sur: Outils
(Tools) ➔ Options d’affichage (Display
Options) ➔Écran d’instructions (Guidance
Screen) ➔ Auto/Manuel (Auto/Manual).

Partie III – Menu Affichage (View)
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3.  Liste des itinéraires (Affichage (View)
➔ Liste des itinéraires (Route List))

Affiche des instructions textuelles vous
expliquant comment parvenir à votre
destination

Partie III – Menu Affichage (View)
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Partie III – Menu Affichage (View)

4.  Infos GPS (Affichage (View) ➔ Infos
GPS (GPS Info))

Affiche les informations d’état du GPS et
d’autres informations utiles

Temps universel (UTC Time) – Temps
universel coordonné
Heure locale (Local Time) - L’heure dans
la zone où vous êtes

Sous Position (Location), vous verrez
aussi votre Latitude, Longitude et Altitude.

NMEA - National Marine Electronics As-
sociation (Association nationale de
l’électronique marine).  Les informations
affichées dans cette fenêtre affichent
certaines des données reçues par l’unité
GPS.
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Partie III – Menu Affichage (View)
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Partie III – Menu Affichage (View)

5.  Almanach (Affichage (View) ➔ Almanach
(Almanac))

Affiche les informations concernant le Soleil/
la Lune
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Partie III – Menu Affichage (View)

6.  Zoom avant/Zoom arrière (Affichage
(View) ➔ Zoom +/Zoom -) – Cliquez ici pour
faire un zoom avant ou un zoom arrière sur
la zone.  Vous pouvez aussi utiliser les icônes
+/- sur le bas de la carte.



110

Dépannage

Garantie limitée

Pour une liste plus complète des instructions de dépannage et le FAQ, veuillez vous
reporter à la section Dépannage (Troubleshooting) et Forum aux questions (Frequently
Asked Questions) dans le logiciel du système de navigation (Fichier (File) ➔ Aide (Help)).

1.  Pendant l’installation des cartes, un message d’erreur d’écriture de fichier
s’affiche.
Il se peut que cela soit causé par une mémoire disponible insuffisante sur votre ordinateur
ou votre PDA.  Veuillez installer les cartes sur un autre emplacement, ou bien installez
plus de mémoire sur votre appareil.

2.  Mon GPS Bluetooth IOGEAR ne parvient pas à déterminer sa position.
Veuillez vous assurer que votre unité est bien située à l’extérieur, éloignée des bâtiments
ou structures élevés, ou des objets qui risquent de causer des interférences.  En outre,
assurez-vous également que l’unité GPS est bien à pleine charge (il faut environ trois
heures pour charger complètement l’unité).
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Dépannage

Si vous ne parvenez pas à déterminer la position, réinitialisez le GPS en suivant les
instructions données dans le Guide de démarrage rapide du matériel.

3.  Mon PDA ne répond plus ou devient très lent après que j’ai chargé le Système de
navigation.
Tout d’abord, vérifiez que votre PDA a bien la configuration minimale requise.  Vous
pouvez également vérifier quels sont les programmes en cours d’exécution sur votre
PDA.  Si vous avez trop de programmes fonctionnant en tâche de fond, il se peut qu’ils
occupent une portion de votre mémoire système, ce qui ralentit le PDA.

4.  Le logiciel de navigation ne se charge pas sur mon PC/PDA.
Vérifiez que votre périphérique a bien la configuration minimale requise.
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5.  J’ai des problèmes pour établir la communication Bluetooth entre mon PC/PDA
et l’unité GPS.
Veuillez consulter le Guide de démarrage rapide du matériel pour les instructions
concernant ce point.  Si vous avez toujours des problèmes, veuillez consulter le manuel
de l’utilisateur de votre périphérique Bluetooth.

Dépannage
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Spécifications
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Spécifications
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Si vous avez besoin d’une assistance technique, veuillez consulter la Bibliothèque
d’informations techniques d’IOGEAR® (Tech Info Library : T.I.L.) sur www.iogear.com/
support pour les derniers trucs, astuces et conseils de dépannage.  La TIL IOGEAR®
a été conçue de façon à vous apporter les dernières informations techniques concernant
nos produits.  Vous y trouverez les réponses à la plupart de vos questions, aussi nous
vous demandons de bien vouloir la consulter avant de prendre contact avec l’assistance
technique.

L’assistance technique est disponible du lundi au vendredi de 8:00 am à 5:00 pm
heure Pacifique, et vous pouvez nous joindre au (949) 453-8782 ou par courrier
électronique à support@iogear.com.

Assistance technique



116

Déclaration sur la réception radio et television

AVERTISSEMENT !  Cet équipement génère, utilise et peut rayonner une énergie de
radiofréquence et s’il n’est pas installé et utilisé conformément au guide d’utilisateur, il
peut générer des brouillages avec les communications radio.  Cet équipement a été
testé et trouvé respecter les limites définies pour un équipement informatique de classe
B dans la sous-section J du Rôle 15 des règles de la FCC, qui ont été conçues pour
apporter une protection raisonnable contre ce brouillage lors de l’utilisation dans le
cadre d’un environnement commercial.  L’utilisation de cet équipement dans une zone
résidentielle risque de générer des brouillages, auquel cas l’utilisateur se verrait dans
l’obligation de prendre toutes mesures nécessaires pour corriger le brouillage.
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Garantie limitée

En AUCUN CAS, LA RESPONSABILITÉ DU REVENDEUR DIRECT NE SAURAIT
ÊTRE SUPÉRIEURE AU MONTANT RÉGLÉ POUR LE PRODUIT, QUE LES
DOMMAGES AIENT ÉTÉ DIRECTS, INDIRECTS, SPÉCIAUX, ACCIDENTELS OU
CONSÉCUTIFS RÉSULTANT DE l’UTILISTATION DU PRODUIT, DU DISQUE OU DE
SA DOCUMENTATION.

Le revendeur direct n’offre ni garantie ni représentation, implicite, explicite ou statutaire
quant au contenu ou à l’exploitation de la documentation et décline plus
particulièrement toute garantie en matières de qualité, performance, commercialisation
ou adaptation à une application donnée.

Le revendeur direct se réserve également le droit d’éditer ou de mettre à jour le
dispositif ou la documentation sans devoir être tenu à avertir un individu ou une entité
desdites éditions ou mises à jour.  Pour toute demande d’informations
supplémentaires, contactez votre revendeur direct.
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