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The IOGEAR Bluetooth GPS system is a real-time navigation system. The
Bluetooth GPS receiver allows you to receive positioning data from satellites and
connect to mobile computing devices via Bluetooth, without cables. It provides
high position accuracy and reliable tracking capabilities. The ultra low-power
design and long-life rechargeable battery gives you 25 hours of continuous usage
and eliminates constant recharging between uses. It is portable and lightweight,
so you can put it on the dashboard or any other location that provides a direct line
of sight to the sky.

You will never get lost again!
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System Requirement

Laptop/Desktop:

Windows ME/2000/XP
A minimum of 256MB system RAM and at least 512MB of free hard disk space
Must be Bluetooth-enabled and support serial port profile

PDA (Pocket PC):

Requires Microsoft Pocket PC 2002 or later
PDA must have at least 266 MHz processor with at least 64MB of free main memory
At least 64 MB storage card to load additional maps is recommended
Must be Bluetooth-enabled and support serial port profile
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Software Installation
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Checklist

Before proceeding, please check the following:

• This guide assumes you already have Microsoft ActiveSync installed and
   configured to transfer data between your PDA and computer.

• Connect your PDA to the computer via its cradle or synchronization cable



Software Installation
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Install the Software

1.  Insert the setup installation CD that
came in the package.  The CD will
auto-start and begin the installation
procedure.

2. The installation wizard will present
you with the window below.  Press
Next to continue.



Software Installation
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3.  If you accept the license
agreement, click Yes.



Software Installation
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4.  On the next window, you
can select the version of the
navigation software that you
wish to install.  Please make
your selection below, then
click Next.



Software Installation

5. Wait a few moments
as the installation files
are transferred to your
computer.
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6.  If you checked the “Pocket PC”
box, you will get a prompt similar to
the image below.  If you wish to install
the program in your PDAs main
memory, click Yes.

Software Installation

However, if you wish to install the
navigation software in an alternate
location, click No.  You will then be
presented with a window where you
can specify where to install the
program files.  Click OK to confirm
your selection.
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Software Installation
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7. The software will prepare the files
to be installed on your PDA.

8. Check your PDA for additional steps
to complete program installation.
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9.  Click Finish to complete
the installation.

Software Installation



Software Installation
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10. Installing Maps

Once you have loaded the map
software, you can select the maps
that you wish to install on your
device.  There are two methods to
install your maps – by region, or by
city.  If you have less than 64MB of
storage, it is recommended to install
maps “By City.”  However, if you have
sufficient storage space, you can
install your maps using the option By
Region.

If you look on the right-hand side, you
can select the Target Location where
you want to load the maps (on your
PDA or computer).  You can also see
here the available storage space of
your selected location, and the size in
megabytes of your selected maps.

Method 1 - By Region:

Using this option you can install
maps for an entire state.  If the state
of your choice has a “+” sign next to
it, it means that you can choose to



Software Installation
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Alternatively, if your Computer/
PDA has limited storage space,
you can load maps using the
option By City.

install only portions of that state
(as illustrated by the image
below).  To load the entire state
map, simply make sure that any
boxes below the “+” sign are
checked.

Once you have selected all
desired maps, click on “Generate
Map” to begin map installation.



Method 2 - By City:

First select a Region (state) for
your desired map.  Next select
the city, and the map radius in
which you plan to use the GPS
system.

Under Target Location, specify
where you want to load the
maps.  When you’re ready to
being map installation, click on
“Generate Map.”

Software Installation
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Software Installation

11.  The installation software will
now begin installing your maps.
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Software Installation

12.  Depending on your selections, you
may be prompted to insert the CD where
your map data is located.  Please do so
and click OK to continue.

Note:  Please be patient as map
installation may take up to 30
minutes, depending on the size of the
maps being loaded.



Software Installation
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13.  Once installation is completed,
you will see a window like this:
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Configure the Software to use with your GPS

Checklist

Before proceeding, please check the following:

• Make sure you have installed the Navigation software on your device

• You have installed all your desired maps

• Your Computer/PDA has established a Serial port connection with your GPS
unit, as described in the “Hardware Quick Start Guide.”  If you do not carry out
this step, the software will not be able to find the GPS unit.

Note: Instructions provided here are for PDA software.  However, the steps for the PC version of the
software are almost identical.
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Configure the software to use with you GPS

Go to your programs folder on your
PDA and tap on the map icon
located there to load the navigation
software.

1.



Configure the software to use with you GPS

At start-up, you will be presented
with a warning message on steps to
follow to ensure your security while
using your GPS equipment.  Simply
click OK to continue.

2.
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3. If you have already established
GPS position, the map will display
your current location.  Otherwise, it
will display the last known location.

Configure the software to use with you GPS
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Configure the Software to use with your GPS

The icons you see on the screen allow you to quickly change the most used
settings for your navigation software.

Allows you to turn volume on/off.

Allows you to enter a destination, change to map view, change route/
display options, set speed alert, record track information, adjust
volume, and view GPS Info.

View GPS Info

Change your orientation
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Configure the Software to use with your GPS

If you would like to access other
features of the software, please click
on the File, Tools, and View menu,
located on the bottom of the window.

NOTE: Once you are using the map for navigation,
if you do not tap on the PDA screen, this menu on
the bottom will auto-hide.  To bring it back up,
simply tap anywhere on the PDA screen.



File Menu

Among the tasks you can do here
include entering a destination to
display block-to-block directions,
record your trip or playback a
recorded trip.  If you want to see a
demonstration of your trip, you can
click on Start Demo to see a
demonstration of your route.

Configure the Software to use with your GPS
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Configure the Software to use with your GPS

Tools Menu

This menu offers some useful features
such as speed alert, display options
(standard view, 3- view), automatic
detection of the GPS unit (auto detect),
and voice commands volume.
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Configure the Software to use with your GPS

View Menu

Under the view menu, some of the
most useful links are GPS Info that
allows you to check how many
satellites your GPS unit is linked to;
Almanac which gives you information
about Sunset/Sunrise, and Moon
phases; and Zooming In/Out feature.

For detailed instructions on using the
software, please consult the
navigation software user manual
included on the setup CD.
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Configure the Software to use with your GPS
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The first thing we want to do is
configure the navigation software
to detect the Bluetooth GPS unit.
To do this, click on Tools, which
will bring up a menu like the
following:

4.
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Configure the Software to use with your GPS

5.  Now, select Tools > Auto Detect.



The navigation software will begin
detection of your GPS unit.
Simply click OK to begin scanning.

6.

Configure the Software to use with your GPS
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At this point, if your PDA has not
established a connection with
your Bluetooth GPS, you may get
a window displaying all the
Bluetooth devices in your range.
If so, please select the Bluetooth
GPS and click OK.

7.

Configure the Software to use with your GPS
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You may also be prompted to enter a
Passkey or PIN Code.  If so, please
enter “0000” (four zeroes), and then
click OK.

Configure the Software to use with your GPS
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Configure the Software to use with your GPS

Once the software has detected
your GPS, you simply have to
click OK to confirm the settings.

8.
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Configure the Software to use with your GPS

Note: If the software cannot detect your
GPS unit, please make sure a Bluetooth
serial connection is established
between your device and GPS.
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Configure the Software to use with your GPS

Once you have established
connection to the GPS unit, you
will be taken to the map view.

9.
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The next step is to verify that the
GPS has established its position.
To do this, click on View > GPS
Info.

10.

Configure the Software to use with your GPS
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Configure the Software to use with your GPS

If the GPS unit has established its
position, you will see something
similar to the window below.  The
green bars indicate the satellites to
which the GPS unit is linked to.
The red bars indicate that a link to
that particular satellite has not
been established.  In order to use
the GPS, you need to be
connected to at least three (3)
satellites.

11.
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GPS position established:

In this case, you can see that the
GPS is connected to 5 out of 8
satellites:

Configure the Software to use with your GPS
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GPS Position Unknown:

In this case, you can see that the
GPS unit has not established its GPS
position and is not linked to any
satellites (indicated by the red bars).

Configure the Software to use with your GPS
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If your GPS unit has problems linking to satellites, please try the following:

• Move the GPS away from any tall buildings/structures
• Move GPS away from any object that can interfere with wireless signals
• Place the GPS in a location where it has a clear view to the sky (preferably
outdoors)

Configure the Software to use with your GPS
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To begin using the software, click
on File > Enter Destination.

1.
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How to use the software



How to use the software

As you see from the figure below,
you can set a destination from
among the different categories.
For this example, we will select
Address.

2.
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How to use the software

The next window will display the
currently selected State.  If you wish
to change this, simply click Change
and select the desire State for which
you have already loaded a map.

In our example, we will select California,
and select City First.

41

3.



How to use the software

Now enter the city name and then
click the green OK button.

4.
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Enter the street name, and then
click on the green OK button.

5.

How to use the software

43



Enter a number based on the valid
range displayed, and then click the
green OK button.

6.

How to use the software
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use the software

Based on your selection, you will
be presented with the possible
destinations.  Please select the
correct one, and then click OK.

7.

How to use the software
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How to use the software

You will then be taken to the map
view.  If you are off the road, your
map will indicate so and prompt you
to drive to the nearest road.

8.

46



Once you are on the road, the map
will display your location on the map
and give you block-to-block
directions.

9.

How to use the software

For more detailed instructions on using
the navigation software, please consult
the Navigation User Manual.
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