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Welcome

Thank you for purchasing the IOGEAR Bluetooth GPS System.  This Bluetooth
GPS unit is a real-time navigation system. The Bluetooth GPS receiver allows you
to receive positioning data from satellites and deliver the data to mobile computing
devices wirelessly via Bluetooth. It provides pinpoint accuracy and thoroughly
reliable tracking capabilities. The ultra low-power design and long-life recharge-
able battery gives you 25 hours of continuous usage and eliminates constant
recharging between uses. It is portable and lightweight, so you can put it on the
dashboard or any other location that provides a direct line of sight to the sky.

You will never get lost again!
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System Requirement

Laptop/Desktop:

Windows ME/2000/XP
A minimum of 256MB system RAM and at least 512MB of free hard disk space
Must be Bluetooth-enabled and support serial port profile

PDA (Pocket PC):

Requires Microsoft Pocket PC 2002 or later
PDA must have at least 266 MHz processor with at least 64MB of free main memory
At least 64 MB storage card to load additional maps is recommended
Must be Bluetooth-enabled and support serial port profile
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Software Features

•  Turn-by-turn voice prompts help you to stay focused on the road

•  Automatic rerouting help you to get to your destination even if you make a

   wrong turn

•  Quickest, shortest, local, major, carpool route options

•  Auto Maneuver guidance screen

•  Real time map display

•  Auto full screen

•  Detailed map display w/ street names

•  Automatic day and night color scheme
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•  3-D bird eye view

•  Hot keys option for command shortcut through your PDA’s buttons

•  Special safety features include speed and fog alert

•  Large Points of Interest (POI) database

•  Favorite and recent destinations

•  Easily accessible status box displays ETA, distance, and speed

•  Record and playback track

•  Demo mode gives you a driving simulation of your trip

•  Navteq map database

Software Features
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Software Installation

Checklist

Before proceeding, please check the following:

• This guide assumes you already have Microsoft ActiveSync installed and
   configured to transfer data between your PDA and computer.

• Connect your PDA to the computer via its cradle or synchronization cable
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Software Installation

Install the Software

The installation wizard will present
you with the window below.  Press
Next to continue.

1.

2.

Insert the setup installation CD that
came in the package.  The CD will
auto-start and begin the installation
procedure.
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Software Installation

If you accept the license
agreement, click Yes.

3.
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Software Installation

On the next window, you
can select the version of the
navigation software that you
wish to install.  Please make
your selection below, then
click Next.

4.
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Software Installation

Wait a few moments as
the installation files are
transferred to your
computer.

5.
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If you checked the “Pocket PC” box,
you will get a prompt similar to the
image below.  If you wish to install
the program in your PDAs main
memory, click Yes.

Software Installation

However, if you wish to install the
navigation software in an alternate
location, click No.  You will then be
presented with a window where you
can specify where to install the
program files.  Make your selection
and then click OK.

6.
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Software Installation

The software will prepare the files to
be installed on your PDA.

Check your PDA for additional steps
to complete program installation.

7. 8.
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Click Finish to complete the
installation and proceed to
the next section.

Software Installation

9.
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Loading Maps

1. Once you have loaded the map
software, you can select the maps
that you wish to install on your
device.  There are two methods to
install your maps – by region, or by
city.  If you have less than 64MB of
storage, it is recommended to install
maps “By City.”  However, if you have
sufficient storage space, you can
install your maps using the option By
Region.

If you look on the right-hand side, you
can select the Target Location where
you want to load the maps (on your
PDA or computer).  You can also see

here the available storage space of
your selected location, and the size in
megabytes of your selected maps.

Note: When you select the map areas to install,
the navigation software builds a map joining all
these areas together.  If you wish to add more
areas at a later time, the navigation software will
need to reconstruct the entire map; therefore,
you need to select all your previous maps, plus
the one you are adding.

Method 1 - By Region:
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Loading Maps

Using this option you can install
maps for an entire state.  If the
state of your choice has a “+”
sign next to it, it means that you
can choose to install only
portions of that state (as
illustrated by the image below).
To load the entire state map,
simply make sure that any boxes
below the “+” sign are checked.

Once you have selected all
desired maps, click on “Generate
Map” to begin map installation.
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Method 2 - By City:

First select a Region (state) for
your desired map.  Next select
the city, and the map radius in
which you plan to use the GPS
system.

Under Target Location, specify
where you want to load the
maps.  When you’re ready to
being map installation, click on
“Generate Map.”

Loading Maps
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Loading Maps

The installation software will now begin
installing your maps.

2.
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Loading Maps

3.  Depending on your selections, you
may be prompted to insert the CD where
your map data is located.  Please do so
and click OK to continue.

Note:  Please be patient as map
installation may take up to 30
minutes, depending on the size of the
maps being loaded.
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Loading Maps

4.  Once installation is completed, you
will see a window like this:
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Configure Software to Use with GPS Unit

Checklist

Before proceeding, please check the following:

• Bluetooth unit is ON and has an unobstructed view to the sky

• Your Computer/PDA has established a

• Make sure you have installed the Navigation software on your device

• Make sure you have installed all your desired maps
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Establish a Bluetooth Serial port
connection between your Computer/
PDA and your Bluetooth GPS unit,
as described in the “Hardware Quick
Start Guide.”  If you do not carry out
this step, the software will not be
able to find the GPS unit.

1.

Configure Software to Use with GPS Unit

Go to your programs folder on your
PDA and tap on the map icon
located there to load the navigation
software.

2.
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At start-up, you will be presented
with a warning message on steps to
follow to ensure your security while
using your GPS equipment.  Simply
click OK to continue.

3.

Configure Software to Use with GPS Unit
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4. If you have already established
GPS position, the map will display
your current location.  Otherwise, it
will display the last known location.

Configure Software to Use with GPS Unit
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The icons you see on the screen allow you to quickly change the most used
settings for your navigation software.

Allows you to turn volume on/off.

Allows you to enter a destination, change to map view, change route/
display options, set speed alert, record track information, adjust
volume, and view GPS Info.

View GPS Info

Change your orientation

Configure Software to Use with GPS Unit
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At the bottom of the screen, there are
three menu options: File, Tools, and
Menu.  For a detailed explanation and
discussion of these menus, please go
to page 48.

Configure Software to Use with GPS Unit
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Configure Software to Use with GPS Unit

The first thing we want to do is
configure the navigation software to
detect the Bluetooth GPS unit.  To
do this, click on Tools and go down
to GPS Options.

5.
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Configure Software to Use with GPS Unit

Now, select Auto Detect.6.

42
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Configure Software to Use with GPS Unit

The navigation software will begin
detection of your GPS unit.
Simply click OK to being scanning.

7.



32

Configure Software to Use with GPS Unit

At this point, if your PDA has not
established a connection with your
Bluetooth GPS, you may get a
window displaying all the Bluetooth
devices in your range.  If so, please
select the Bluetooth GPS and click
OK.  However, if after several
attempts the navigation software
cannot find your GPS, please make
sure that you have followed the
procedure indicated on the Hardware
Quick Start Guide to establish a
Serial port connection between your
device and the GPS unit.

8.
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You may also be prompted to enter a
Passkey or PIN Code.  If so, please
enter “0000” (four zeroes), and then
click OK.

Configure Software to Use with GPS Unit
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9.Once the software has detected your
GPS, you simply have to click OK to
confirm the settings.

Configure Software to Use with GPS Unit



35

Configure Software to Use with GPS Unit
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Once you have established
connection to the GPS unit, you will
be taken to the map view.  Please
proceed to the next section “Verify
GPS Satellite Connection.”

10.

Configure Software to Use with GPS Unit
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Verify GPS Satellite Connection

The next step is to verify that the GPS
has established its position.  To do
this, click on View > GPS Info.

1.
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If the GPS unit has established its
position, you will see something
similar to the window below.  The
green bars indicate the satellites to
which the GPS unit is linked to.  The
red bars indicate that a link to that
particular satellite has not been
established.  In order to use the GPS,
you need to be connected to at least
three (3) satellites.

2.

GPS Position Established:

In this case, you can see that the
GPS is connected to 5 out of 8
satellites:

Verify GPS Satellite Connection
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Verify GPS Satellite Connection

GPS Position Unknown:

In this case, you can see that the
GPS unit has not established its GPS
position and is not linked to any
satellites (indicated by the red bars).
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Verify GPS Satellite Connection

If your GPS unit has problems linking
to satellites, please try the following:

• Move the GPS away from any tall
buildings/structures

• Move GPS away from any object
that can interfere with wireless signals

• Place the GPS in a location where it
has a clear view to the sky (preferably
outdoors)
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Introduction - Getting Started

Map View

Turn to make

Next Street

Distance until
destination

Current location



42

Shortcut Icons

As you can see on the image above, there are a number of shortcut icons on
your screen that allow you to easily access the most common tasks associated
with your navigation software.  To access all the features of the software, click on
the File, Tools, and View menu on the bottom of the screen (explained later in
the manual).

Introduction - Getting Started
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In the section below we will briefly explain what each of these functions are and
explain their use.

Introduction - Getting Started

Allows you to turn ON/OFF the sound for the navigation system

View GPS status information

Change map orientation
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Introduction - Getting Started

GPS Status Icons
These icons are displayed on the map area and represent the following:

GPS Status: Linked to satellites

GPS Status: Attempting reconnection

GPS Status: Not linked to sufficient satellites
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Map Option

Introduction - Getting Started

These icons allow you to do the following:

Displays the surrounding area of selected destination on the map

Displays your current position on the map

To set an address as a Favorite, click on this button
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Introduction - Getting Started

If you wish to see the surrounding
areas of your current location on the
map, use the panning feature.  To do
this, tap on the PDA screen and hold
down the stylus on your map and
move it along the direction that you
would like to see and then release the
stylus.  The map will then focus on
that location.  To exit this mode and
go back to your current position, click
on the red X located on the bottom
right-hand corner.

Panning Map
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Introduction - Getting Started

Tapping on the menu icon will take
you to the main menu shown below
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Part I - File Menu

1. ENTER DESTINATION
(File Menu ➔ Enter Destination)

This menu option allows you to set a
location and provides you block-to-
block directions.  As you see from the
menu below, there are several ways
to set a destination.

We will provide a few examples
below for your reference.  If you still
need assistance, please use the help
menu in the navigation software by
going to File ➔ Help.

File Menu
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Part I - File Menu

A. Set Destination - Address

When you select the Address option,
you are presented with the two choices
below:

Street First – Using this option will
typically yield more search results but
is very helpful if you’re having trouble
finding a specific address

City First – This option is very useful
because it narrows down search
results to the city that you specify
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Part I - File Menu
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Part I - File Menu

Street First
Enter the name of the street and then
click the green OK button.
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Now enter the house number of your
destination, making note of the valid
range displayed.  Next, click the green
OK button to proceed.  Note: If your
address falls outside of the range
displayed, you probably do not have
the map required for that area.  This
could be the case if you loaded your
maps using the option “by city.”  If
that is the case, please load a larger
radius area for your map, or select
the option “by region” when loading
your map.

Part I - File Menu
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Part I - File Menu

The navigation software will now display
a list of the matching addresses.  As
mentioned earlier, using the “street first”
option will typically yield several
matching addresses.  Select your
address, and then click OK on the top
right-hand corner.
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Part I - File Menu

City First
Enter the name of the city and then
click the green OK button.
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Now, enter the name of the street and
then click OK

Part I - File Menu
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Part I - File Menu

Enter house number, making note of
the specified range.



57

The navigation software will display
the matching addresses found.  As
you can see below, using the “city
first” option helped to narrow down
search results.  Select desired
address, and click OK on the top right-
hand corner.

Part I - File Menu
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Part I - File Menu

B. Set Destination - Intersection

Using this option, you can enter the
names of two intersecting streets as
your destination

Street First
It is not suggested to select this option
for an intersection because most of
the time it will yield too many results.
However, if you only loaded a small
map section on your device, you will
not encounter this problem.
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Part I - File Menu

Enter the name of the first street and
then click OK
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As you see, there were too many
matching records.  Click OK to try the
city first option.

Part I - File Menu
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Part I - File Menu

City First
Enter the name of the city and then
click OK
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Enter the name of the first street and
then click OK

Part I - File Menu
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Part I - File Menu

Enter the name of the second street
and then click OK
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In this case, the navigation software
did find a matching for that
intersection, and using the “city first”
option helped us to narrow down the
search results to only one matching
record.  Simply click OK on the top
right-hand corner to display the map.

Part I - File Menu
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Part I - File Menu

C. Set Destination – City Center

This will find the center of your city.

As an example, we will choose the
Alphabetical option.
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Part I - File Menu

Enter the name of your city and then
click OK.
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Part I - File Menu

Now, click on the OK button on top right-
hand corner.  If you click on Nav on the
bottom, the navigation software will
show you a map of the destination.
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Part I - File Menu

Here is a map of the city center found
in Irvine, CA.
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Part I - File Menu

D. Set Destination – Points of Interest

The navigation software has a very
useful feature called Points of Interest
(POI for short).  As you can see from the
image below, these POIs are classified
into categories for easy access.

As an example, we will select Attraction.
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Part I - File Menu

Under attraction, we find the subcatego-
ries listed below.  We will choose
Amusement Park for our example.
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Make your selection from the list
below.  Let’s select Alphabetical to see
all the amusement parks close to our
area.

Part I - File Menu
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Part I - File Menu

From the list below, make your selection,
and then click OK.
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To display the map of your POI, click
OK on the top right-hand corner.
Alternatively, you can click the Nav or
Map icon on the bottom of the screen.

Part I - File Menu
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Part I - File Menu

E. Set Destination – Contacts
You can also set a destination from
someone in your contact book for
whom you have entered an address.
Please note that the address of the
contact needs to be in a proper
format in order for this feature to
work.  For assistance on this,
please consult your PDA manual/
user documentation.

Also, if your contact book is empty,
you will get an empty window like
below when you click on this.
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If you do have someone in your contact
book, their information will be displayed.
Please make your selection and then
click OK.

Part I - File Menu
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Click on your contact to display their
address.

Part I - File Menu
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Part I - File Menu

F. Set Destination – Favorites

To select a destination that you have
previously entered as a Favorite
Destination, click on this selection.
Make your selection from the list and
click on Nav or Map icon on the bottom.
Note: You can edit, or delete an
entry from this window by clicking
the Edit or Del icon, respectively.
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Part I - File Menu

G. Set Destination - Recent

All your recent destinations that you
have used are stored in this place.  If
you wish to set one of them as your
destination, simply select them from
the list below and then click Nav or
Map icon on the bottom to display
map.



79

Part I - File Menu

2. SAVE CURRENT LOCATION
(File ➔ Save Current Location)

Allows you to save your current
location on the map.  This location
will be saved in your Favorites folder.
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Part I - File Menu
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3. CANCEL ROUTE
(File ➔ Cancel Route)

Use this to cancel a route that you
have entered

Tip: To verify that the route was
cleared, you can click on View ➔
Route List, which should show an
empty window like this:

Part I - File Menu
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Part I - File Menu

4. RECORD TRACK
(File ➔ Record Track)

To record your trip, click on record
track, which will display the window
below.  Enter the requested
information and then click OK to
begin recording.
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5. PLAY TRACK
(File ➔ Play Track)

Playback a previously recorded track

To playback a previously recorded
track, click on play track and select
the file you wish to playback.  Tip: To
stop playing the track, click on File ➔
Stop Track.

Part I - File Menu
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Part I - File Menu

6. START DEMO
(File ➔ Start Demo)

One of the most useful features of
the navigation software is the Demo
feature, which allows you to view a
demo of your actual route for the
specified destination.  This is very
useful in case you need to adjust/
change settings on your PDA as
you can comfortably do so before
you begin driving.

Tip:  If you tap on Start Demo and
nothing happens, please keep in
mind that you first need to specify
a destination.
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Part I - File Menu

7. ABOUT NAVIGATION SYSTEM
(File ➔ About Navigation system)

Displays map software information
window
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Part I - File Menu

8. Help
(File ➔ Help)

Displays the built-in help content of the
navigation software.

This is a very useful feature if you need
a quick explanation on how to perform
certain tasks in the navigation software.
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Part I - File Menu

9. Exit
(File ➔ Exit)

Quits the program and unloads it from
your PDA’s memory
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1. SAFETY FEATURES
(Tools ➔ Safety Features)

Help you make your driving safer.

TOOLS MENU

Part II - Tools Menu
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A. Speed Alert
If you wish to receive a sound alert
when you reach a certain speed limit,
enable speed alert.  If you set it to Auto,
the navigation software determines the
speed limit based on the type of road
you are in (street, freeway, etc.).
However, this alert is only provided for
your convenience and is not guaranteed
to be accurate.  We advise you to obey
all speed limits, traffic laws and always
use good judgment when using this
feature.

Part II - Tools Menu
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Part II - Tools Menu

B. Fog Driving
If you enable this option, the software
will notify you when an intersection is
approaching.
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Part II - Tools Menu

2. DISTANCE UNIT
(Tools ➔ Distance Units)

Allows to change the units for
displaying distances on your
navigation software.
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Part II - Tool Menu

3. ROUTE OPTION
(Tools ➔ Route Options)

Customize the software to give you
directions based on your prefer-
ences.  Below is a brief explanation
of these settings.  For more
information, please use the help
menu (File ➔ Help)



93

Part II - Tools Menu

A. Method

Quickest – Gives you directions that will get you to your destination faster
(example taking the freeway for long trips and avoiding local congested streets)

Shortest – Gives you directions based on the shortest route based on physical
distance (may not be the quickest way)

Major – Gives you directions based on major streets (if you don’t want to get lost
on unknown streets)

Local – Gives you directions for local streets only (avoids freeways)
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Part II - Tools Menu

4. DISPLAY OPTIONS
(Tools ➔ Display Options)

Below is a brief explanation of these
settings.  For more information, please
use the help menu (File ➔ Help)
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Part II - Tools Menu

A. Map Orientation – change this setting based on your orientation for better view
of the map

B. Color Scheme
Auto – changes day/night screen view at sunset/sunrise, respectively
Day – screen is in normal view for day viewing
Night – map background darkens and road lines brighten for better view

C. Guidance Screen – if set to Auto zooms in to map when approaching that area,
else you have to
                                 click on the area manually.
D. POI Icons – if turned on, map displays icons when driving by POI locations from
the map database

E. 3D Map View – you can change the view of the map to 3D view for a more
realistic view
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Part II - Tools Menu

5. HOTKEY OPTIONS
(Tools ➔ Hotkey Options)

Assign a button on your PDA to a
specific task

This is a very useful feature of the
software as it allows you to assign
any of your PDA’s buttons to perform
some of the navigation software
functions by simple push of a button.

Simply select a function from the list,
and then click the button on your PDA
that you would like to perform that

function.  Upon doing this, you should
see the button # displayed under the
tab called “button.”  If you want to undo
it, you can click Clear Key to do this for
the selected function, or “Clear All” to
clear all assigned buttons.
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Part II - Tools Menu

The functions you can assign to a PDA button are:

3D Mode
Current Position
Customize POI Icons
Detour
Display Options
Enter Destination
Fullscreen
GPS Info

Menu
Mute
North/Heading Up
POI Icons On/Off
Route List
Route Options
Speed Alert
Volume
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6. INPUT OPTIONS
(Tools ➔ Input Options)

Allows you to define how to enter
information for the navigation system

Part II - Tools Menu

Pocket PC Keyboard – all user input
needs to be done through your
PDA’s on-screen keyboard (in this
case by tapping on the keyboard
icon you see on the bottom right-
hand corner of the image below).
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Part II - Tools Menu

Navigation System Keyboard – uses the
navigation software built-in keyboard for
all input.  This is much more convenient
as the keys are displayed bigger on the
PDA, and you can still use your Pocket
PC keyboard if you’d like to.
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Part II - Tools Menu

7. GPS OPTIONS
(Tools ➔ GPS Options)

Manually select the settings for your
GPS unit or set to Auto Detect
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Note: The COM port number is the
Outbound COM Port number that your
Computer/PDA use to connect to the
GPS unit.  Only set this manually if
you’re sure what COM port your PC/
PDA use.

The Baud Rate should be set to 4800

Part II - Tools Menu
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Part II - Tools Menu

8. GUIDANCE VOLUME

(Tools ➔ Guidance Volume)

Allows you to adjust the volume level
of the navigation system for the voice
commands.
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Part III - View Menu

VIEW MENU

1.MAP
(View ➔ Map)

Takes you back to map view
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Part III - View Menu

2. GUIDANCE
(View ➔ Guidance)

Zooms in to your current position
and informs you the next maneuver
(ex: turn left/right).

Tip: By default, this is done
automatically by the navigation
system.  If you wish to change this,
go to: Tools ➔ Display Options ➔
Guidance Screen ➔ Auto/Manual.
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3.  ROUTE LIST
(View ➔ Route List)

Displays text instructions on how to get
to your destination

Part III - View Menu
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NMEA - National Marine Electronics
Association.  The information
displayed under this window displays
some of the information received by
the GPS unit.

Part III - View Menu

4. GPS INFO
(View ➔ GPS Info)

Displays GPS status information and
other useful information

UTC Time – Coordinated Universal
Time

Local Time – The time in your area

Under Location, you can also see your
Latitude, Longitude, and Altitude.
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Part III - View Menu
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Part III - View Menu

5. ALMANAC
(View ➔ Almanac)

Displays Sun/Moon information
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Part III - View Menu

6.  Zoom in/Zoom out
(View ➔ Zoom +/Zoom -)

Click on this to zoom in/out of an area.
Alternatively, you can use the blue +/-
icons on the bottom of the map.



110

Troubleshooting

For a more complete list of troubleshooting/FAQs, please see the Troubleshoot-
ing and Frequently Asked Questions section in the navigation system software
(File ➔ Help).

1.  During map installation, I get a file write error.
This can be caused by insufficient memory space on your Computer/PDA.
Please install maps in an alternate location or install more memory on your
device.

2.  My IOGEAR Bluetooth GPS cannot establish position.
Please make sure that you have the unit in an outdoor area, away from tall
buildings/structures or any objects that may cause interference.  Also, make sure
the GPS is fully-charged (it takes about 3 hours to achieve full charge).
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If you still cannot establish position, reset the GPS as instructed in the Hardware
Quick Start Guide.

3.  My PDA becomes unresponsive or very slow after I load the Navigation
System.
First, make sure your PDA meets the minimum system requirements.  You also
may want to check all the Running Programs on your PDA.  If you have too many
programs running on the background, they may be consuming your system
memory; thus slowing down the PDA.

4.  The navigation software does not load on my PC/PDA.
Please make sure your device meets the minimum software system require-
ments.

Troubleshooting
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5.  I’m having trouble establishing Bluetooth communication between my
PC/PDA and GPS unit.
Please consult the Hardware Quick Start guide for instructions on how to do this.
If you still have trouble, please consult the user manual for your Bluetooth device.

Troubleshooting
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Specification
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Specification



115

If you need technical support, please check out our IOGEAR Tech Info Library
(T.I.L.) at www.iogear.com/support for the latest tips, tricks, and troubleshoot-
ing.  The IOGEAR  T.I.L. was designed to provide you with the latest technical
information about our products.  Most of the answers to your questions can be
found here, so please try it out before contacting technical support.

Technical support is available Monday through Friday from 7:30 am to 5:30 pm
PST and can be reached at (949) 453-8782 or by email support@iogear.com.

Technical Support
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Radio & TV Interference statement

WARNING!!!  This equipment generates, uses and can radiate radio frequency
energy and, if not installed and used in accordance with the instruction manual,
may cause interference to radio communications.  This equipment has been
tested and found to comply with the limits for a Class B computing device
pursuant to Subpart J of Part 15 of FCC Rules, which are designed to provide
reasonable protection against such interference when operated in a commercial
environment.  Operation of this equipment in a residential area is likely to cause
interference, in which case the user at his own expense will be required to take
whatever measures may be required to correct the interference.
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Limited Warranty

IN NO EVENT SHALL THE DIRECT VENDOR’S LIABILITY FOR DIRECT,
INDIRECT, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES
RESULTING FROM THE USE OF THE PRODUCT, DISK OR ITS DOCUMENTA-
TION EXCEED THE PRICE PAID FOR THE PRODUCT.

The direct vendor makes no warranty or representation, expressed, implied, or
statutory with respect to the contents or use of this documentation, and especially
disclaims its quality, performance, merchantability, or fitness for any particular
purpose.

The direct vendor also reserves the right to revise or update the device or
documentation without obligation to notify any individual or entity of such revisions,
or updates.  For further inquires please contact your direct vendor.



23 Hubble     Irvine, CA 92618      (P) 949.453.8782     (F) 949.453.8785      www.iogear.com

Contact info.


